Bltouch not leveling Properly

What is the problem?
The print is not level and i am using bltouch with leveling enabled
What did you already try to solve it?
change the start gcode, changing z offset, and changing the config file

Also adjusting the z motor mount to make it was level
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

using Marlin 1.1.9 bugfix with bltouch enabled

Creality 1.1.5 mainboard

Is it something in the firmware I need to change?

Let's start with the easy things before we look into your firmware.

  • How did you determine the Z-offset?
  • Post your start gcode
  • does the bltouch work as intended? does it deploy and snap back in when it touches something?

Sorry as soon as I wrote this topic I solved it. Thanks anyway. I had to level the bed manually because when I looked at the bed visualizer it was slanted by 3 mm. So I leveled that and it worked no problem.