BLTouch not stopping extruder

Ender 3 with BTT SKR Mini E3 v1.2, BTT TFT35 E3 v3.0, BLTouch, Octoprint 0.16

This is a printer my brother gave me configured as is without any notes. I have checked that the BLTouch is connected to the main board on the z-stop header.

I am new to 3d printers and am just trying to configure it so the nozzle is set to the right height prior to attempting to print anything. Right now when I attempt a home the nozzle touches the bed and I can see the springs slightly compress (obviously a bad thing).

I switched the display from BTT to Marlin 2.0 and with motion/home z and a with a block under the probe tip, the extruder stops correctly. It appears this is an issue with z-offset but I am having trouble finding the correct place to adjust. I am nervous to try anything as I don't want to damage either the nozzle/hot end/extruder etc or the bed.

Since the printer is set up with OctoPrint on a RPi 3B I thought maybe he only configured these settings under that, but I'm not seeing anything in any guides that confirms OctoPi can override the mainboard settings. I can see that there is a bed visualization in OctoPi so I know the BLTouch is configured somehow but I'm at a loss to find where.

I've downloaded the OctoPi 0.18 image and was considering starting over with configuration but thought I'd hold off until I at least asked the community.

Hello @bkenobi !

Have you updated the firmware to use the BLtouch?

You can not just swap the genuine Z-axis endstop with a BLtouch. That device works different.

Yes, I downloaded the version with the z stop (firmware-bltouch-for-z-homing.bin), renamed to firmware.bin, and put it on a microSD before starting up the printer. It gave an error on the display:

Failed to enable Bed Leveling  echo:Bed Leveling OFF  echo:Fade Height OFF  ok

From what I read in a thread on BTT community, that was normal on first boot because the bed mapping had not been stored.

When I go into the display under movement/ABL/Offset it was originally set to -1.85. Since the extruder was touching the bed, I backed that off to -1.50 but it seems to do the same thing. At that point, I stopped and posted here.

I tried running a ABL procedure with a SD card plastic case as an offset. After completing the process, I can see that the OctoPrint bed visualizer is updated. I don't seem to get the error when booting the printer. If I use the box under the probe such that it's also under the nozzle tip and run a z home the nozzle seems to stop when it barely touches the box. I tried different thickness items and it seemed ok. I tried with a piece of paper and it seemed ok too (I could move the paper after the probe retracted). But if I stretch the paper tight under the probe, it pinches at the nozzle. Perhaps this suggests there is some kind of warping where the probe is lower than the nozzle? I thought movement/ABL/offset would help here, but it doesn't seem to help (or I'm using it wrong).

Since I'm not finding the z-offset setting that appears to be needed, I thought updating the firmware might be in order. After doing a lot of reading, I've cloned the Marlin firmware and config as well as the BIGTREETECH-SR-mini-E3 repositories. There are many guides on compiling, but I haven't succeeded yet in generating a valid firmware. Seems the config I updated based on a guide posted on Reddit by u/qwewer1 looked really promising but when I compiled it complained about versions etc.

You can use a BL-Touch as endstop replacement (with the endstop pins) - but you still have to set it up in the firmware.

1 Like

That is what I meant with:

Maybe not that straight forward...

1 Like

It looks like there are 2 ways to set the BLTouch up. One with the z limit replaced by the sensor. The other way with the z limit still in the mix and the BLTouch pins at a different location on the board. Mine is set with the BLTouch as the z limit switch and the original firmware supposedly had it all working. I'm just trying to make sure the z offset backs the nozzle off a little.

When I tried to compile the firmware again, I was able to get it to build without error. When I used the one I generated from the Reddit guide I posted, the z limit did NOT kick in and the extruder went too far so I had to kill the power real quick! I replaced with the official precompiled one ( on BTT github) and home worked as expected. I replaced that with the one that came with the printer for now since I don't know if I need anything else custom yet.

I have Ender3's that print hundreds of parts before I need to reset the Z offset, using a magnetic surface means I never remove parts when the bed is on the printer, hacking a part off will wreck the levelling you tried so hard to set.

BL-touch sensor probes are fragile, so I'd only use it for ABL. At least with the SKR miniE3 you have the choice. None of my printers use a BL-touch, although they are great for compensating for non-flat heated bed surfaces, and some Creality aluminium heated beds are far from flat.

I use 80g copier paper as my clearance gauge because a feeler gauge is hard spring steel and is likely to damage the nozzle, especially a coated one.

How tight you set the 'feel' of the paper depends upon the print surface - I use PEX or PEI, which are totally flat and they need a good squish of the first layer and 70 degree bed temperature, if you are using a PC mat, or a 'bobbly' PEI sprayed surface you don't need so much as the surface texture helps the print to stick and you can drop the bed temp to 40 or 50 degrees.

I've got a CR10SPro and it has no Z microswitch, just the gantry mounted sensor, the stock capacitive sensor is junk and I had nozzle crashes no end until I replaced it with an inductive sensor, now I get perfect first layer on PEX, BTW an inductive sensor is useless on a glass print surface, Octoprint will generate a print surface map thanks to this bit of genius.. by @jneilliii

Teaching Tech has some great videos on bed levelling e.g.

I was able to get everything working with the help of a friend to spent many hours with me tweaking this thing. Turns out there were a few issues (not a surprise). The primary issue appears to be that the extruder may have been assembled cold and not tightened after installation. The nozzle was extended out by around 2mm and the hotend had a giant pile of schmoo which was hiding the other side backed out 1-2mm as well. After cleaning all the gunk out and reassembling, the hotend actually matches the stock pictures and the BLTouch now deploys before the nozzle impacts the bed.

Second, we switched to Klipper which eliminates having to recompile every time a setting needs to be tweaked. I do miss the ability to use the BTT 35TFT, but I only really wanted that to do movement and monitor the temps anyway so perhaps I can get something working to at least get that back.

A lot of effort, but it has printed the xyz cube and 3DBenchy successfully now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.