Blu View 2. How to find serial port with putty

What is the problem?

I know to use the putty command "dmesg", but don't know the parameters with it to find my tty* port name to use in Octoprint.
Server works, Camera works, but no printer connection.

What did you already try to solve it?

  1. I plugged the usb-c/usb (BV2 charging cord) into my laptop to make sure it was a data cable, it connects for data.

  2. I also connected the Blu View 2 to my Samsung S7 phone, connected them together with the usb-c/usb (BV2 charging cord) & usb/mini usb adapter (samsung provided with phone), it works correctly.

Then I used the cable from #2 (above) and plugged it into the mini-usb port of the printer. (NO GOOD, will not connect to printer).
This may mean the BV2 won't allow users to connect to 3D printers!
Does anyone have ANY INFO about this?

Have you tried running in safe mode?

Not appropriate.

Did running in safe mode solve the problem?

Not appropriate.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/107.0.0.0 Safari/537.36
connectivity.connection_check : 1.1.1.1:53
connectivity.connection_ok : true
connectivity.enabled : true
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : unknown
env.hardware.freq : unknown
env.hardware.ram : unknown
env.os.bits : 32
env.os.id : linux
env.os.platform : linux
env.python.pip : 19.2.3
env.python.version : 3.8.0
env.python.virtualenv : false
octoprint.last_safe_mode.date : 2022-09-02T18:43:20Z
octoprint.last_safe_mode.reason : incomplete_startup
octoprint.safe_mode : false
octoprint.version : 1.8.6
printer.firmware : Virtual Marlin 1.0
systeminfo.generated : 2022-11-09T15:44:33Z
systeminfo.generator : systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I used octo4a v0.0.5 because the latest version wouldn't work at all.
All cables (including y-splitter for charging & data) worked on my lenovo tablet.
The only difference is I had to use a usb-c/usb for the BV2 phone (tested ok on laptop), instead of a mini-usb/usb cable at the lenovo tablet.
Please note:
I think the y-splitter is reversed using the BV2 phone (only way to hookup).

I think if I can find my /dev/tty* address I can get it working.
I tried: /dev/tty*, /dev/usb/001/002, /dev/Octo4a, and many others I don't remember.

Thanks for the help!
BSB

Hello @BindSquirrelBilliard !

Could you please share the Systeminfo Bundle?

Update:
I hooked up my levono tablet again to make sure it worked with these cables, it did.
Then I bought a usb-c (male)/usb-mini (female) and tried it.
at 1st it wouldn't work, too loose on the mini female, so I put a piece of folded up paper to tighten up the connection, IT WORKED!

Now I have a port (/dev/bus/usb/001/007) and it shows connected on phone.
But Octoprint won't connect to it even though I put this address into "Additional Serial Ports" in the Octoprint settings.

Note:
The lovono tablet showed driver & info directly below the connected port on Octo4a.

Not sure what to do next...

Created a backup of Octoprint, but can't find it (cot sure where the default backup is).

Here's the System file.
octoprint-systeminfo-20221110093438.zip (47.3 KB)

Latest update:
I did get a usb address/location (/dev/bus/usb/001/002).

Even used "developer mode" to usb option and tried all 3.

  1. File transfer
  2. PTP
  3. Charging only

Still Octoprint will NOT connect.
I give up...

To connnect using Octo4a, in OctoPrint you must use the /dev/Octo4a serial port option. The printer must be connceted in the Octo4a app first before you can connect in OctoPrint.

Version 0.0.5 of Octo4a is quite old, and so you might try upgrading to the latest version of the app - there have been many bug fixes, including those to make it compatible with OctoPrint 1.8.x.