Board reset if I start/wake up/heat up Octoprint/Desk

What is the problem?

If I try to print some that I have transfer via CURA to the OctoPI (running last OctoPrint and OctoDash) and while the printer heating up, most the Board makes a reset (last Marlin).
So then Octo* goes to sleep. If I touch and wake him up (again), the board right now while Octo* wake up makes the next reset most of the time.
So if I'm sometimes able to have all running and try to print some, the board makes the next reset if the heater goes on (after ~2 seconds)

What did you already try to solve it?

I have checked the PSU (12V30A) and also the board 5v0 and 3v3 and the PI's voltages with a Storage oscilloscope. The power sources are without any drops or anything else, stable and clean.
I also have delete all the startcode in CURA and sliced it again; same as before.
I have placed a 47000µF LowESR direct on the board power clamps to be shure... No change

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.9.2 / GeeeTech I3proC custom, Marlin bugfix-2.1.x (newest), FireFox/Opera/Edge, WIN10x64 (last)

Edit: Some information more...
The board does or is always and reproducibly forced to reset by the OctoPI/Dash/Print in the following situations:

  • Booting the OctoPI
  • Wake up the OctoPI (tap on screen)
  • Job start/heat-up from the OctoPI (manually on the printer display, no problem)
  • Shutting down the OctoPI

Cross test:
Board separated from OctoPI (USB). Identical print file on SD card fed directly to the printer. No problems

Assuming you have installed OctoPi on a Raspberry Pi

That does not happen with OctoPi. Or you shutdown the system from the OctoPrint web GUI.

A lot of printer boards perform a reset when a USB connection is established.

BTW: Its a bit confusing. Obviously you call your Raspberry Pi with OctoPi/OctoPrint on it OctoPi. We actually use the term/name OctoPi only for the software bundle of OS and OctoPrint.

Ok, I didn't know that. Thanks for the clarification.
And yes, I used the name OctoPI for the RaspBerry and OS as well as OctoPrint and OctoDash. That somehow made sense to me. But now it's clear.

No, yes, similar. ^^
So when I shut down the RaspBerry (i.e. the OS with OctoPrint and OctoDash) using the TouchDisplay installed on it, the board resets.
The same thing happens when the RaspBerry is “asleep” because there are no jobs or because the board has previously reset. If I then tap the touch display to wake it up, OctoPrint tries to connect to the printer again (which sometimes leads to a 409 conflict), and the board resets again.
If it worked once without a reset, I select the previously transferred file for printing on the RaspBerry display and say "print this now", then the board resets again as soon as the heaters are started up.

At the moment it is only possible to finish a job or even start it with a lot of patience and luck.
The fact that the board resets with a USB connection would explain the reset at startup and the first connection attempt or during a wake-up call. But when starting a job?
Could it be that the USB connection wobbles from time to time and OctoPrint re-establishes it in the background without noticing it?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.