Booting into emergency mode and then hanging

OctoPrint boots into emergency mode every time I do a fresh installation. Once it says generating ssh keys it says "Failed to write wtmp record, ignoring: Read-only file system." It then says it is going to reboot but never does, so I cut the power and restore. After a little while, it says

 [ TIME ] Timed out waiting for device dev-disk-by\x2duuid-C829\x2dC4C1.device.
 [DEPEND] Dependency failed for file system check on /dev/disk/by-uuid/C829-C4C1.
 [DEPEND] Dependency failed for /boot/efi.
 [DEPEND] Dependency failed for Local File System.

it says press enter to continue, and after I do it hangs, with the carat being frozen solid.

What did you already try to solve it?

I tried multiple different SD cards and many fresh installations, but they all have the same result.

Have you tried running in safe mode?

It is impossible to run it in safe mode because I cannot execute any commands.

Did running in safe mode solve the problem?


Does your Pi boot into non-OctoPi images? Is it brand new or has it worked before?

It has worked before. I have had it for 2+ years, with it bouncing around projects. I actually got it to work with octopi, but after a couple of successful boots, this started happening, so I reburned the image multiple times, all to no avail.

Resolved: used SD Memory Card Formatter for Windows/Mac | SD Association ( to reformat.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.