Both Octoprint servers/printers suddenly not running with no visible problems

What is the problem?

I was at vacation for 2 weeks, and after getting back home I've found that BOTH of my printers are suddenly refuse to run the Web Service. The versions are 1.8.6 and 1.8.7. (I've got also older 1.7.x server on the 3rd printer, and that one still works fine)
Going to WEB interface of the printers I get standard OctoPI message: "The OctoPrint server is currently not running". So the server is working but due to some problem it is not launching the Octopi Interface.

What did you already try to solve it?

Checked the free space - everything is fine.
Checked the log file - nothing critical so far: (UPDATE: actually it is way too short comparing to the older successful runs)

2023-08-08 10:07:20,717 - octoprint.startup - INFO - ******************************************************************************
2023-08-08 10:07:20,733 - octoprint.startup - INFO - Starting OctoPrint 1.8.6
2023-08-08 10:07:20,737 - octoprint.startup - INFO - Starting in SAFE MODE. Third party plugins will be disabled!
2023-08-08 10:07:20,738 - octoprint.startup - INFO - Reason for safe mode: setting in config.yaml
2023-08-08 10:07:20,738 - octoprint.startup - INFO - ******************************************************************************
2023-08-08 10:07:23,285 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity changed from offline to online
2023-08-08 10:07:23,412 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: online
2023-08-08 10:07:23,413 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to is working
2023-08-08 10:07:23,413 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving is working

Have you tried running in safe mode?

Tried running in Safe Mode - no changes.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues

Can't access the dialog..

Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible

All printers connected to LAN through ASUS RC-AC66U, and I can SSH all of them. Octoprint ran from Raspberry PI 2.
Connecting from Android phone, and from Win10 PC.

The launch command does not look 100% exact to Octopring suggested. Suggested:

/home/pi/oprint/bin/octoprint --host= --port=5000


/usr/bin/python3 /home/pi/.local/bin/octoprint

P.S. By analysing the old logs it looks like I've installed some updates to the both printers before going to Vacation. Current and previous logs attached
octoprint.log (3.7 KB)
octoprint.2023-07-20.log (134.8 KB)

Try it via ssh :slight_smile:

Generate it with

~/oprint/bin/octoprint systeminfo .

and download it with WinSCP

1 Like

Interesting... When I run this command it just does nothing and HANGS. I now suppose Octoprint also hangs when ran as service...
But how do I debug it?

My command is bit different due to path - ~/.local/bin/octoprint systeminfo

P.S. Tried verbose - ~/.local/bin/octoprint -v systeminfo . Silence. Nothing.
P.P.S. Ran this command on the other working printer, and it does something for 1-2 minutes, but there's no result.... Where should I search for result?

the dot at the end is missing. it's systeminfo .

It should create a zip file in the current path

1 Like

Thanks for your help! It did not create any file even with dot on the end. On the other printer as well, for some reason.

I gave up and reinstalled OS. (that took 20 mins in comparison with the whole day I spent trying to repair the old one...

Weird. I would at least expect some kind of error message if something is wrong.
But who knows what happened.
Glad you found a solution :slight_smile:

Happy printing :tentacle:

1 Like