Brand new Pi, Brand new SD, No ACT light

I'll start off by saying that my electronics knowledge is not very expansive and got my RPi 4 model b thinking that I would just flash an SD card and plug a couple cables in and have Octoprint up and running.

I have had nothing but problems since I received it. I have probably spent between 18 and 24 hours trying to research what I am doing wrong and trying a multitude of different things. I at least believe I know what the root issue is and it seems that my RPi is not reading the SD card when it boots. Whenever I flash an SD card and boot the RPi, the ACT lights flash for a second and then do not again. Just the solid red power light is on. I have tried the 0.17 and 0.18 versions of Octoprint with no luck. I have tried to recover the EEPROM which ended up giving me 2 long ACT led blinks and then 4 short ones which means "File signature/hash mismatch - Pi 4". I haven't really figured out what that means. I have tried literally every thing I can find on the web with no luck. This was all attempted on two different micro SD cards as well. Both Sandisk Ultras. One is 16gb the other 32gb.

The only thing I can imagine there is to do left is to try to get a new RPi but I figured I'd see if anyone had any suggestions first...

Have you tried flashing any standard Raspberri Pi software to try? As if that boots it's not the Pi...

:arrow_heading_up: and

How did you flash the sd cards?
Did windows ask you after flashing if you want to format the sd card? If yes - did you say yes?

Which Pi 4 is it?

I'm not quite sure what a single led flash means. It's not documented.
Every error code in the list has at least 3 led flashes

I tried the Raspberry Pi OS on the 16gb card and just tried on the 32gb as well with no luck.

SD cards were both flashed with Balena Etcher for OctoPrint. The Raspberry Pi OS 32 bit was done via the Raspberry Pi Imager v1.5. This is all being done on my MacBook so it did not ask me to format the SD card.

This is the RPi 4 model B 2GB.

I apologize for the confusion. I do not believe The ACT flash I am getting as soon as it is plugged in is an error code. This is my first Pi so I am not 100% but from my understanding, what I am seeing is normal when it is powered on. Its maybe 4 or 5 quick flashes with no pattern to them.

Ok, I have 2 important questions:

  • What powersupply are you using? As you cannot use any phone power supply, Computer or genuine USB HUB. You need a dedicated powersupply that can deliver up to 3A. It may be that the RPi doesn't get enough power to boot.
  • What kind of SDCard are you using? Is it at least a Class-10? If not, it may take a while for the bootloader to load. Maybe not hours, but a few minutes isn't unheard of. And on first boot it expands it's storage from the initial size to the full size of the card; This can also take some time, depending on the speed of the card. Did you take this into account?

Power supply is a CanaKit Raspberry Pi 4 USB-C power supply. 5.1v 3.5A. SD cards both class 10. I tried leaving it powered on for an extended period of time. Couldn't tell you how long honestly but it was well over an hour.

In that case I would suggest returning the RPi as DOA; since it won't even load it's own software and you meet all the other requirements... It happens sometimes, either in shipping or what have you.


Darn, I was honestly hoping I was just doing something wrong. On its way back as of a few hours ago. Should have a new one on Wednesday.

Thank you everyone for taking the time to assist me.