Brand New to Octoprint and need help already

What is the problem?

I downloaded Octoprint, used Etcher to flash to my SD card
Opened octopi-wpa-supplicant.txt and edited my wifi information there
then saved and safely removed the SD card
I then installed the SD card on my raspberry pi 4
I opened putty and entered octopi.local, but it won't find it

What did you already try to solve it?

redid all of the above to make sure I did it correctly, still the same answer

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


I have a windows computer, it is up to date
and I am trying to install this on my raspberry pi 4 for my Ender 3 v2 for 3d printing


First try http://octopi instead.
If that also doesn't work post a picture of your octopi-wpa-supplicant.txt and blacken your ssid and the password.
There is probably a typo or something similar in that file :slight_smile:

Uploading: image.png...

I just uploaded the pic of my octopi-wpa-supplicant.txt, but not sure if it went through. I am not very computer savvy, so sorry :frowning:

No it somehow didn't work.
Not quite sure what happened but you have to see the image before posting it :slight_smile:
Let's try it with the octopi-wpa-supplicant.txt.
Just write some sonsense in the ssid and password field and upload the file.

this could be the problem
put a # at the beginning of the country line your aren't using

Ok, did that, saved and tried octopi.local in putty again, but still not finding it

If you have the chance, connect a HDMI TV/monitor to to the Pi.
If it works correctly, the startup sequence will show up.
When it connects to the router, at the end there will be the IP address of the Pi.
You can use that too to connect to the Pi.

1 Like

As @Ewald_Ikemann mentioned you can try it with the ip or or with just octopi (without the .local)
If you can't connect the pi via hdmi to a screen you could try to open your routers webinterface and check if the pi is listed as connected device.

1 Like

Ok, finally got the pi set up, but when I am in this screen it isn’t showing connected to my printer. Did I miss something? Any ideas how to fix it?

First of all - is your printer turned on? (not making fun of you - that happens all the time)

If that doesn't help try it again with an sd card inserted into your printer (and if you already had one in it try it without it)

If that also doesn't work, log into your pi via ssh (putty) then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

I'm having the same issue as well. This is what it outputs after i entered the command you recommended.

Unfortunately the pi doesn't detect the printer.
Try another usb cable, some cables come without data lines.

Thank you. I will get a new cable.

Some USB cables are meant for charging devices and therefore can only supply power and not transmit data. Most cables will transmit data as well as supply power. When you order it make sure it indicates data as well as power. Keep those questions comin'.

.local requires that mDNS is available. mDNS was developed by Apple and is implemented in linux, macos and some routers. If you want your PC to use it make sure you have itunes and BONJOUR (installed as part of itunes installed)
Otherwise, get an IP scanner and scan your network for devices and access via the IP address.

octopi.local I Think you need the use_ name.local BUT I always use the IP address supplied on my Router for pi