BTT CB1 octoprint install

What is the problem?

I cant get octoprint to automatically boot up like it does when to install the octoprint image on a raspberry pi.

I started by installing CB1_Debian11_bullseye_minimal_kernel5.16_20220929.img.xz from the BTT github.

then I followed installation instructions from 3d printscape by Rob

I can get octoprint to run using ~/OctoPrint/venv/bin/octoprint serve. But if I shut down putty or my computer goes to sleep octoprints loose connection to the server.

I ran the sudo service octoprint start and this is what I get

(venv) biqu@BTT-CB1:~/OctoPrint$ sudo service octoprint start
Job for octoprint.service failed because the control process exited with error code.
See "systemctl status octoprint.service" and "journalctl -xe" for details.
(venv) biqu@BTT-CB1:~/OctoPrint$ systemctl status octoprint.service
● octoprint.service - The snappy web interface for your 3D printer
Loaded: loaded (/etc/systemd/system/octoprint.service; enabled; vendor pre>
Active: failed (Result: exit-code) since Sun 2022-10-02 06:40:33 UTC; 17s >
Process: 31371 ExecStart=/home/pi/OctoPrint/venv/bin/octoprint (code=exited>
Main PID: 31371 (code=exited, status=203/EXEC)
CPU: 8ms

Oct 02 06:40:33 BTT-CB1 systemd[1]: Starting The snappy web interface for your >
Oct 02 06:40:33 BTT-CB1 systemd[31371]: octoprint.service: Failed to locate exe>
Oct 02 06:40:33 BTT-CB1 systemd[31371]: octoprint.service: Failed at step EXEC >
Oct 02 06:40:33 BTT-CB1 systemd[1]: octoprint.service: Main process exited, cod>
Oct 02 06:40:33 BTT-CB1 systemd[1]: octoprint.service: Failed with result 'exit>
Oct 02 06:40:33 BTT-CB1 systemd[1]: Failed to start The snappy web interface fo>
lines 1-13/13 (END)

What did you already try to solve it?

multiple different installation instructions this is the furthest I have got. I don't have much experience with Linux

Have you tried running in safe mode?

No.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: True
connectivity.enabled: False
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: unknown
env.hardware.ram: 1032310784
env.os.bits: 64
env.os.id: linux
env.os.platform: linux
env.python.pip: 22.2.2
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: 2022-10-02T01:13:42Z
octoprint.last_safe_mode.reason: incomplete_startup
octoprint.safe_mode: False
octoprint.version: 1.8.4
systeminfo.generated: 2022-10-02T06:49:18Z
systeminfo.generator: zipapi

WRITE HERE

That's how Linux works; when started like this, the octoprint process is "owned" by the shell process opened via putty. Closing putty closes the sell process, which kills all the processes it has open. See (for example) this article for details: 4 Ways To Keep A Command Running After You Log Out Of The SSH Session

It looks like the service file references octoprint being installed for the pi user (ie: in /home/pi/octoprint), but you seem to have it installed for the biqu user (ie: in /home/biqu/octoprint). You will have to edit the .service file accordingly.

1 Like

Most solid OctoPrint install on a Linux system - for my opinion - is:

1 Like

This script is pretty good too...handles installing webcam options and setting it all up as a service. GitHub - paukstelis/octoprint_install: Bash script for installing OctoPrint and webcam streamer

2 Likes

Did you ever get this sorted out? Having the same issue with my CB1 install even with changing all the Pi users to the Biqu user account setup on the Bigtreetech debian install.

What benefits does using BTT's image or 3rd party guides over any of the official OctoPi images or installation guides give you?

If there is an issue with BTT's OS install, then questions/support for this should be directed to them, not the OctoPrint community.

The CB1 kernel isnt fully compatible with the PI standard build so we have to follow the manual install from Foosel to install. Why would BTT care about a software install?

I think I understand better what the situation is, and what you did was a bit different to the OP in that case.

I thought that the image you had from BTT was one with OctoPrint pre-installed, however the OP had actually followed some 3rd party install guide and then never replied when it was suggested to use the official guides.

In the issue above, they have not followed a step to change the usernames from pi to whatever their username was. If you have done that, you probably have a different issue and it might be best to open your own topic for the different problem instead of the OPs.

This was the perfect fix for the CB1 - Thanks