BTT Octopus V1.1 USB connection problem

I have a Pi4 that I tried to connect to a BigTreeTech Octopus V1.1 board via the USB-C cable with Marlin 2.1.2.

What did you already try to solve it?
I tied every combination of serial port settings in Marlin. ( I mean every one, enabling one, two and three ports included.) Even disconnected the screen and tried only to get the board and Pi to communicate.
I also used a different cable to connect. Even tried using the USB_2 and USB_3 ports on the Pi.

I dont have logs, it will be too much.

DOES ANYONE HAVE THE SAME ISSUE?
ANY solution, suggestions?

I did connect the board and the Pi eventually, but not over USB_C cable. I enabled the Pi's Serial_1 and connected to the boards Serial_2 connection. It works, but would be cool to get the USB_C connection going....

The connection from the Pi to the printer is not a network issue.

You may ask the Marlin guys @ Marlin how to enable USB-C support.

I'm having a similar issue with mine. I just setup an Octopus V1.1 and even Pronterface fails to connect to it. I'm am plugging mine in with USB-C on the board to USB-B on my computer. The only other option would be USB-B to B...which is just weird to do. As far as I can find, serial 1 is the TFT/LCD and serial -1 is 'USB.' But this board has two possible USB options.
The computer does recognize the serial device and I am selecting the correct serial COM #.

I am sad that this is seen as Marlin "only" issue. I suspect Marlin is part of it. Sorry for the intrusion, just trying EVERYTHING to solve it.

Wolf, as for your connection to PC. I found that my Pi can detect the board, but not connect. I suspect an compatibility issue off the comms, but I don't have the knowledge to solve it. I suspect your USB-B to USB-B may have the same issue, but would be interesting to know, if you can find such cable.