C920 seems to only stream 4:3 low quality?

Camera model
Logitech C920

What is the problem?
I changed the config file to "USB" camera, and added resolution settings for 1920x1080 and 15fps.
On the 'control' page, the camera still shows up fairly low quality, and it's a 4:3 aspect ratio instead of filling the full widescreen.

What did you already try to solve it?
Changed the config file, that's all I knew to try.
Edit: In the octoprint webcam page, there's a setting to swap between 4:3 and 16:9, but it's already on 16:9. I toggled it just in case, but no effect.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
No logs, because... I mean what log would help with this?

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Current version of Octoprint (1.3.12, far as I know). Pi 3b+.

Have you fix your issue ?
I also has the same problem.
I edited /boot/octopi.txt but resolution still the same.
I am using Pi4 2GB with Logitech C920, OctoPrint version 1.4.0

Do you use any plugins that uses or controls the webcam?

The video on controls display wrong resolution and aspect ratio. Even I changed to 16:9, the video show exactly same as nirurin shown above.

also tried different resolution in octopi.txt, but resolution never change for me.
#camera_usb_options="-r 640x480 -f 10"

#camera_usb_options"-r 1280x720 -f 30"

#camera_usb_options"-r 1280x720 -f 15"

#camera_usb_options="-r 1280x720 -f 20"

#camera_usb_options="-r 1280x720 -f 25"

So you're using octolapse.

Did you use them with the # ?
You know you have to remove the #, right?
Also you forgott the = a few times

Did yo set camera="usb" ?

Yes, I did removed the #
Sorry for my typo, but I do have '=' in the config file

K alright.
Please upload your octopi.txt and webcamd.log.
Click on logs for further instructions.
Just zip them and upload them here :slight_smile:

I found the root cause of my webcam issue.
It is cause by The Spaghetti Detective plugin.
Problem gone once check the 'Disable premium webcam streaming' setting inside The Spaghetti Detective plugin 'Advanced Setting tab'.

Yep that's why I asked you that

1 Like

Thanks, didn't thought it cause by the plugin

Okay, so we now know that Spaghetti caused your problem. But if you don't visit the plugin author's repository and create an issue, he'll never know.

Yes, I created already (in github)

1 Like

This is currently expected behavior on USB cameras. https://www.thespaghettidetective.com/docs/more-about-webcam-streaming/#i-configured-webcam-aspect-ratio-to-be-16-9-in-octoprint-settings-but-it-has-become-4-3-now-that-i-have-the-premium-webcam-streaming-why