" Cache entry deserialization failed, entry ignored" on Python 3 migration

What is the problem?

Got this message in a continuous loop at terminal after trying to migrate to python 3. "Cache entry deserialization failed, entry ignored"

After letting it do this for about ten minutes, I hit ^C and tried the python3 upgrade.py command again and it told me that my Python version was already Python3 and asked me for a path to another venv. Uninterested in that mess, I just re-imaged the card with version 18.

What did you already try to solve it?

Nothing I didn't mention in the problem described above. This is purely here for reference purposes so others who encounter it can chime in.

Have you tried running in safe mode?

No, nor am I going to. Life is too short to troubleshoot a problem that's too easily fixed by a fresh image.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Ha! No I can't. Octoprint won't start.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version 1.7, octopi 17, printer is a cartesian made of garbage, Marlin 1.1.8 (yeah... I should probably update that, despite it's complete irrelevance to this topic... , OS was the pi's, since I did this in a PuTTY session... I did have printgenius installed...

'Cache entry deserialization failed' should eventually stop, I'm surprised it did that for 10 mins but it was probably installing the packages and on each one pip's cache failed.

The error message is generated by pip, I don't have control over it nor can I supress it without suppressing any errors which would not be great. As far as I know leaving the install to run should be fine, but of course if cancelled mid-way OctoPrint won't start back up again.


Yeah, I figured it was pip, but this was a bone-stock octopi 17 from the imaging software with only print time genius installed.
Installed the 1.7 update and got the python 2 prompt. Double checked my versions and ran that script from the repo and ended up with the 10+ minutes of the error message.

Not a huge deal to me, as all my files are saved locally and the printer I use has an easy profile to set up, so it was quicker and easier to just re-image, but I thought that, because of the very limited amount of modification that I've done to the install, that you may be likely to see more people reporting this. If not... that's cool too. It wouldn't be the first time that the cosmic rays have made me an outlier. :slight_smile:

I just tried updating to OctoPrint 1.7 and needed to also update to python 3. Received the exact same message. However, everything seemed to work and I am now running OctoPrint 1.7 on OctoPi 0.17.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.