Camera, filament sensor and temps don't work after upgrade

What is the problem?

Recently upgraded to Python 3 with a clean install (couldn't do a direct upgrade), then recovered from a backup. Everything seems fine, but I've been finding little issues, and wondering if they're all related.

So far these include:

  • OctoLapse not working with my Pi Camera, but works for built in Timelapse and all other settings
  • Octoprint not waiting for the hotted or printbed to get to temp before beginning to print
  • Filament sensor has stopped working

It's possible they are all unrelated, but I'm thinking some control piece isn't happy.

Note I am running TH3d custom Marlin firmware, but everything was woking up until my OctoPrint upgrade.

My guess is either I ran some code etc on my previous build that enabled all of these, or the new version doesn't have something they all rely on. My Last resort will be to re-flash the firmware (I see there is a slightly newer version), and trouble shoot each problem one-by one, but I'm wondering if anyone has encountered a similar issue and can quickly see what I'm missing

What did you already try to solve it?

Double checked all settings, and diagnosed the pi camera. New issues arrived so now wondering if there's something bigger

Have you tried running in safe mode?

I have not, yet

Did running in safe mode solve the problem?

Doubt it

Systeminfo Bundle (46.8 KB)


Octoprint Version 1.7.3, Octopi 0.18.0, Creality CR-10S5, firmware Marlin TH3D U1.R2.A8, on a Raspberry Pi 3 Model B Rev 1.2


Hi o/

Sorry for the late reply :slight_smile:

Unfortunately I can't help you with that one, because I never used OctoLapse.

That's something your slicer should put in the start gcode. There are two gcodes for heating up:
one that just sets the target temperature at goes on (used for example to change the temperature on the fly mid print) and another one that sets the temperature and waits until it's reached.

For the bed temperature those are M140 and M190 - for the hotend M104 and M109.
Open your gcode in a text editor and check if those are missing.

Is your filament sensor connected to the Pi or the printer?

Not a worry. Thanks for the help

I think you're right about the hotted issue. I have them set to M140 and M104 which don't wait to reach temp. Just weird that it used to do it before. Maybe a bug in my old setup that forced it.

The filament sensor is connected directly to the printer. That's partly why this all seems weird, as I would assume the printer connection makes the "pause on filament" a hardware control, and not related to the Octopi. Again, maybe I did something with my old setup that I've forgotten.

Perhaps you had something is GCode scripts that didn't get restored.

In theory it’s something In OctoPrint (or more generally something on the SD card in my RaspPi), since my slicer Cura didn’t have any changes.

Having said that I’m starting to wonder if either a) the old version worked in an old/broken way that the new version has “fixed” causing this new behaviour. Or B) I ran some odd script on the Pi previously that modified the software at some code level that caused those behaviours


Decided to do a full firmware refresh/update, also new TH3D unified 2, and that seems to have fixed most of the issues and reset some problems. Pi camera is still failing, must just be another problem and coincidental, I can tackle that. My only guess for the other problems is that python 3 didn’t agree with the TH3D unified 1 in some way, and/or the update reset some “fix” I previously made to accommodate python 2.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.