Camera (KB X250) not detected after startup

Hi all,

I am using octoprint with a Kaiser Bass X250 camera for monitoring & time lapses. This is similar to a GoPro camera; it's not actually a web/usb camera but it has an option to function as so.

The problem is that once I power the PI (and consequently the camera) I have but a few seconds to select this option on the camera before the PI finishes starting up. After it starts-up it never detects the camera again, it it wasn't already streaming.

Is there anything I can do for it to be able to detect and use the camera after startup?

Let me know if any aditional information is required.

Thanks in advance

You would be better off contacting their tech support and see if there is a way to force the camera into USB mode on power up. Octoprint cant do that for you

Hi @5ft24,

thank you for taking time to respond to my issue.

I realize I will always need to manually switch camera into USB mode (unless the camera itself has some something to make that default like you said). The problem is that I need to do this before octoprint fully starts, otherwise it will never detect the camera. I will just give a couple of examples to clarify what I mean:

Case 1:

  • I Power the raspberry pi , which in turn powers the camera
  • I very quickly (under 3-5s) turn the camera into usb mode
  • Octoprint detects camera and all is well

Case 2:

  • I Power the raspberry pi , which in turn powers the camera
  • I take a little longer (> 5s since power-up) to turn the camera into usb mode
  • Octoprint does not detect the camera, and never will

So basically what I wanted is for octoprint to be able to detect the camera after startup, because it is very tricky to turn it into usb mode that quickly

I'm thinking that /etc/rc.local might be your friend.


@OutsourcedGuru thanks for stepping in.
I'm afraid I'm not very well versed in Linux system, and couldn't understand your suggestion. What do you think I should with rc.local?

^ That step—if it's something that you run—should be introduced to /etc/rc.local before the final line which exits.

ah, I see what you meant now. Perhaps I didn't express myself clearly: turning the camera into usb mode is made through the camera's own buttons/menus, not on the pi

You might check to see if there's some option to have this camera change modes programmatically. Otherwise, there may no way of getting this to work.

Ok, just to be clear. The issue I'm asking for help is here is not the camera mode change; I am ok with doing that manually. The problem is that I need to do it before the pi finishes it startup. Basically I just needed some way to tell the pi to re-check for connected cameras after startup, or something like that

One might consider adding a delay into the /etc/init.d/octoprint script before it loads the service. If one were clever, one might even add a litmus test with a while loop to wait for the expected device to show up.

I see what you mean. That will work reasonably well I guess; not as good as being able to detect the camera anytime but should do the trick