Camera loads when testing, but not in Control tab

Camera model
Eufy Solo IndoorCam

What is the problem?
I've setup valid HTTP stream and snapshot URLs to a camera, and I can see them when trying "Test" in Octoprint Webcam settings, though when I save and try in Control tab, nothing loads.

My setup is a little complicated, but should work fine. It's a Eufy camera that supports RTSP stream, and I'm using Restreamer to create a HTTP stream from that. Both Octoprint and Restreamer are in Docker containers sharing the bridge network running on a Synology NAS.

What did you already try to solve it?
I've verified:

  • The URL works fine when I try either RTSP or HTTP stream in VLC.
  • The URL works fine on other devices on the network.
  • When I ssh into the Octoprint Docker container, I'm able to curl the contents of the HTTP stream URL without issues, so connection is fine. (And other containers are connecting across the bridge network without issues)

I've tried:

  • I tried in Firefox and Safari. In Safari both tests work fine, though in Firefox only the snapshot test works and the stream test never shows anything.
  • I have my Octoprint setup as, so I've tried testing there and directly connecting locally via localServerIP:8088 which both have the same results
  • I've tried moving the Restreamer Docker container to use the host network instead of bridge network
  • OctoPrint Safe Mode, no difference

Out of ideas, any troubleshooting steps are appreciated! TIA

Logs (28.2 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctoPrint Version 1.8.1 (7.5 KB)