Camera recognized in command line but camera server not starting

Camera model

arducam 5mp OV5647

What is the problem?

I can enter libcamera-still --list-cameras it shows: Available cameras

0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
Modes: 'SGBRG10_CSI2P' : 640x480 [58.92 fps - (16, 0)/2560x1920 crop]
1296x972 [43.25 fps - (0, 0)/2592x1944 crop]
1920x1080 [30.62 fps - (348, 434)/1928x1080 crop]
2592x1944 [15.63 fps - (0, 0)/2592x1944 crop]
yet that camera server won't start. I am using the new camera stack too.

What did you already try to solve it?

I have tried the classic restart, unplugging it, and changing the config files. nothing has worked.

Have you tried running in safe mode?

Yes, I have.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (157.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Build 2023.07.20.144556 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.1

I got this photo off the raspberry pi but still no response in octoprint.

it worked perfectly before I got the autofocus drivers as described here too. For 5MP OV5647 Motorized Focus Camera - Arducam Wiki