Camera stopped working


#1

What is the problem?
I set my octopi up with an off brand pi camera using one of the many guides available. It was working great for several days. I printed a case for it and the camera. When trying to assemble the camera case I found the camera was not a good fit and accidentally disconnected the “sunny” yellow connected on the front of the camera. I put it back and finished connecting it back to the printer. When I logged on to Octoprint the camera feed just says “Webstream is loading”. Any ideas?

What did you already try to solve it?
I have tried disconnecting and reconnecting the camera and ribbon.
I have replaced the ribbon.
I have purchased a pi cam 2 and replaced the offbrand camera.
I have reformatted the SD and did a fresh install.
I used a different SD and did a fresh install.
I tried the various local octopi links. Nothing shows up in octopi when testing the feed through settings.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Hi!
Have a look at the end connector if the small stripes are still ok or some are bended or deattached.


#3

I replaced the cable ribbon between camera and pi and no change.


#4

Assuming that you're trying to use the Raspberry Pi Cam 2 camera, then look for the camera's LED to be powered on when you turn on the Raspberry Pi. If it's not, then the likeliest cause is that you've accidentally flipped one or both cable ends from the way it should be. The connector side of the ribbon cable always goes down toward the board.

Since you're re-imaged, then make sure that you've run sudo raspi-config and have turned on the webcam feature.


#5

I verified the ribbon pins were facing the right way on both the pi and cam. The off brand cam has a red light but the pi cam 2 I am trying won’t light up. I’m worried maybe I broke the connector port on the pi? I didn’t realize the black latch lifted so I was just pushing and pulling the ribbon.

I have gone into the Rapsi-config and turned on the cam already.

Is there a possibility a setting on the pi itself is corrupted? Not the SD card but the board? I didn’t think it had any internal memory.


#6

In case you didn't know this, there is a high incident of out-of-box failures for the v2.x Raspi camera, for what it's worth.

As long as you rebooted after doing the sudo raspi-config bit, then this should bring in the version of the elf file in the firmware that includes camera support.

In this case, it looks like the off-brand is closer to working.

On my autonomous tank, I accidentally cracked one of the side pins on the little black sliding latch on the Raspberry Pi Zero W. When in the OPEN state, it just falls off which makes it more difficult to put back on but it's still functional otherwise.

Review the photos here in my step-by-step tutorial for details about those little black latches.


#7

Got frustrated enough that I ordered another Pi. Put the USB and cam in it, turned it on, and all works fine. I can only assume that I somehow damaged the cam port. Thanks all for the tips and suggestions!


#8

@Woodan21 Glad to hear it. I know that I managed to screw up one of those on a particular Raspberry Pi Zero W. I'll eventually swap it with another but since I soldered some pins on it, I'll just deal with the issues.

Recycle that one to another project that doesn't need a webcam and drive on. :+1: