Camera stream looks like snow

#1

I have a Logitech C270 plugged into my pi 3b+. Was working fine, then I installed Octolapse. Adjusted the config file until I got it working, made some nice lapses, and was pretty happy with it.

And then I wasn't. The picture turned into snow. So I rebooted the pi, and it became colored snow with a basic shape. Rebooted, almost a good picture. Rebooted, snow. Rebooted - wait, now it's working again!

So this happens on and off every few days. As I write this I'm on reboot #10 to try and get it back working.

Thoughts?


config from octopi.txt:
camera_usb_options="-r 1280x720 30"

Octoprint 1.3.12
Octolapse 0.3.4
Creality Ender 3

#2

Adding log files.
octoprint (1).log (169.7 KB)
plugin_octolapse.log (24.3 KB)

And a picture:
Capture

#3

Had the same issue tried a different USB port and rebooted and it went buddy

#4

My other Logitech cameras dont do it incidentally.

#5

Just a wild stab in the dark, but what if it's related to the amount of shared GPU memory?

sudo nano /boot/config.txt

Adjust gpu_mem=128 to gpu_mem=256, reboot, retry. You can always put it back if it wasn't that.