Camera stream not loaded, but stream is ok

Camera model

Cheap model from AliExpress: 6.49€ |Webcam USB haute clarté 12,0 MP 6 LED, veilleuse, caméra Web, micro intégré pour PC portable | AliExpress

What is the problem?

The camera stream is not loaded, but when I click on teh stream URL it show the image in the new tab of the browser.
the url of the stream is http://HomeLab.local:8001?action=stream
My installation came from GitHub - paukstelis/octoprint_deploy: Bash script for rapid deployment of multiple octoprint instance on a single machine
I run octoprint in a Lenovo thincentre M910q with debian 12

What did you already try to solve it?

I'm a totally newbie it's the first time I install octoprint, so I don"t know where to start

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (16.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Check your browser's error console for the reason why it is not loading.

You also cannot mix hostnames & IP addresses or http/https connections within the same page. So if you access OctoPrint via IP, then the browser will not let you embed something that comes from a hostname.

Thanks for the reply
When I inspect the browser console it said that the stream has been blocked by CORS policy: The request client is not a secure context and the resource is in more-private address space private

One of the fix would have been to use https, but since I don"t know how to do that (yet), the easy fix was in the browser flags (eg chrome://flags ) disable Block insecure private network requests

And it works, know I can see the stream in octoprint :slight_smile: