Can connect from Windows 10 but cant from iOS

Dear community, I am new to the 3D Printing world, have been printing for a couple of weeks now and things seem to be working mostly fine, with exception to connecting from my mobile devices to monitor prints.
My printer is a Prusa MK3S which I assembled myself from the Kit (after 10 hours) :slight_smile:

Thanks a lot for your help to address this issue!

What is the problem?
I can connect to my Octoprint server running on Raspberry Pi 4 from Windows 10 without any issues.
But if I try to connect from my iPad or iPhone pointing a browser to the Octoprint IP Address (http://192.168.168.21) it wont work, I also tried with octoprint.local and with 80:80 as ports, no connection, as if the Octoprint server wouldnt exist.
I configured OctoPod on my iPhone and worked fine for some days, now I am getting: "Connection Failed: Service Is down or Incorrect Port".
I tried to use OctoClient App on iOS, I never was able to get a successful connection to the Octoprint server.

What did you already try to solve it?
Verified that I am on the same network, checked network configuration, IP Ranges are the same.
Checked with and without httpS.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
octoprint.log (20.9 KB)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware,

OctoPrint 1.4.0 running on OctoPi 0.17.0
Raspberry Pi 4
Windows 10 Version 10.0.18363.836
iPhone 11 Pro (iOS 13.4.1)
iPad Pro 11" (2018) (iOS 13.4.1)

Thanks a lot for your help!

Dear community I found exactly what the problem was. I needed to "Enable Multicast Enhancement" on my Unifi Controller.

I am using 2x Unifi-AP-AC-Pro on my network. To enable this you need to go to: "Settings" > "WiFi" > Edit your Wifi network > uner "Miscellaneous" turn on the "Enable Multicast Enhancement" option.

Your APยดs will restart, reconnect to your network and then everything should work fine.

Hope this helps someone else having the same problem as I, as it took me a while to figure what was going on :wink:

The strange thing is that when I configured the Pi some days back, I was able to use it without many issues from my mobile...anyways, with the above parameter its now fixed. :wink: