Can no longer drag/drop files to the webpage, webcam freezes after downgrade to 1.7.3

What is the problem?

I had installed the 1.8 version and had the problems listed in the forums, so I followed the directions to revert back to 1.7.3. After that I can no longer drag and drop files from my computer to the webpage to upload them. I have to click the "upload" button to add the files. The webcam also freezes after a few seconds. If I reload the webpage, it will show again for a few more seconds, and then freeze again.

What did you already try to solve it?

Not sure what to try.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, same issues.

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.67 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1800.0
env.hardware.ram: 1909264384
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.5
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.1
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.safe_mode: True
octoprint.version: 1.7.3
systeminfo.generator: zipapi

Additional information about your setup

Octoprint 1.7.3, after downgrading from 1.8. Ender 3 V2.

Remaining system info downloaded from octoprint: (109.7 KB)

I know the power supply is an initial question for some of these issues. I'm using the CanaKit 3.5A Raspberry Pi 4 Power Supply

I've had this power supply the entire time I've used the RPi for Octoprint.

Could you try another browser / another device an check if you got the same issue there?
If it works on other browsers/ devices try to clear your browser cache.

I tried that and had the same result.

I decided that maybe it just needs a fresh install. I wasn't worried about the plugins or files, so I got the 2022-01-28-octopi-bullseye-armhf-lite-1.0.0.img image from the downloads page. I used the Raspberry Pi Imager to install the image to the card and started the Pi back up.

Now the webpage won't work, and I get the " The OctoPrint server is currently not running" page. I ran the command given there and got the proper results, although "python" was in red at the end of the /home/pi/oprint/bin/python.


I did an FTP into the Pi and saw that the python folder wasn't there. What do I do now?

I have an update. For some reason, the page started working again. And I can upload by dragging and dropping the files onto the page. The webcam still freezes after a little while, which it didn't do before. It's not an expensive camera, it's just this cheap webcam.

For the record, that is an release candidate of OctoPi. I'd strongly recommend against using that unless you intentionally want to help in testing a future release. Instead, use the stable version of OctoPi, it is kept up to date and ships right with OctoPrint 1.8.0.

I had the same problems that were being reported in the forums with 1.8.0 so I had to revert to 1.7.3. Is that not a stable version of 1.7.3?

No, the actual OS you are using is the release candidate version. The current stable OctoPi version is 0.18.

Pretty much every issue I can see that people ran into with the update to 1.8.0 has been solved in the relevant posts you are mentioning.

I have some important prints that I have to finish before the weekend, but after I'll update again and see if I have any issues.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.