Can no longer publish gcode from PrusaSlicer to Octoprint (HTTP 500 error)

What is the problem?
I can no longer publish gcode from PrusaSlicer to Octoprint. It worked 2 days ago and I don't think/remember any updates.
When I do I get Prusaslicer error "Error uploading to print host: HTTP 500"
Honestly don't know if this is a Prusaslicer issue or OctoPi or OctoPrint.

What did you already try to solve it?
Rebooted everything
Updated API key
ran Octoprint connection test (passes)
Everything else behaves normal, i can SSH in, connect to it, OctoPod connects to it, Octoprint can control the printer, I just can no longer publish files to it from Prusaslicer.
Tried another computer/instance of Prusaslicer that I also used to be able to publish from PrusaSlicer

Logs (syslog, dmesg, ... no logs, no support)
I'm not very good with this part yet but can follow instructions to retrieve the info I need.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I am having the same problem.

Make sure you have updated the Dashboard plugin to the latest version - the original post is missing a systeminfo bundle to properly work out what the issue is, but recently there has been an issue with Dashboard.

The most up-to-date version is 1.19.5.

1 Like

Hmmmm, I had the same problem firstly after I have updated to the latest release of this plugin last week. So I had to fall back to an earlier backup of my Octoprint image.
Can you please tell me when the up-to-date version 1.19.5 was released? Is it possible to fall back to an earlier release of this plugin if the update will fail again and where to find?

I have the same issue with the "Slicer Estimator plugIn".

3 days ago:

No one has been able to confirm in this thread that the dashboard plugin is actually the issue, since we have not seen a systeminfo bundle to show the actual error. All the issues reported to the plugin author have been fixed. You can find all the previous releases from the link above.


Hi Charlie,

thanks a lot for fast response! I was on 1.17.0. I think I did my first update to 1.19.4.
Now updated to 1.19.5 and the problem is still there. I fall back to my latest image.

What I have seen is, that 1.19.5 needs Phyton 3.6 or later and I am on 2.7.13. I do not know which PlugIn release started to be only compatible with 3.x…

I know I should update but I had too many issues with other plugin especially with “Custom Control Editor” which is also very usefull for me. I keep it on an old version since otherwise it loses often it’s configuration.

I cannot provide with System Info bundle because I am running on an old system (Octoprint 1.4.2, Octopi 0.16.0 and Phyton 2.7.12). Since I do not like some constrain features of the later Octoprint distributions I will stay on this old one. In consequence I think I have to live with the old PlugIn`s and will freeze the current setup on my Pi. However thanks a lot for support!


Life is going to start getting harder and harder for you if you insist on staying on outdated/unsupported versions. 40 plugins do not support Python 2 and this will only increase. Of course, we cannot force you to do anything but things are much easier when you stay up to date so I urge you to rethink your opposition to running up to date software.

As a community we are also unable to help people who are not up to date, since so many issues are solved by updating, and we can't keep track of what has changed in every version to help people properly.

1 Like

Hi Charlie,
you are absolulty right!
I did not recognize before the update that 1.19.5 is not comaptible to the old Phyton and I think that is the problem.
So for me I don't see a solution if I do not upgrade my system but I am fine with the current system. But here I am afraid that I will loose some older plugins which I love and if I do all the updates of the system I have to re-configure a lot of my plugins... too much work.

Regards and again thanks for support!

Too much work for you to upgrade, I guess we're putting in too much work trying to get people to upgrade their Python version. Not worth the last year I have spent on this project.

My issue was resolved updating Python and OctoPi to the latest.

1 Like