Can not access Octopi via browsers


#1

I am trying connect to Octopi today but my Microsoft Edge said error, website cannot found. Uh? I did connect to Octopi last years with same pc.

My iPhone can connect to Octopi with no problem using Https://Octopi.local/
But my iPhone can not handle model viewer so I am stuck in Wizard menu and cannot carry on to print the model...

I am using current Octopi version ( updated it via my iPhone ) and M3D newer firmware version ( not mod )

Pc - window 10 with Microsoft Edge. ( did try out Chome, classic IE but did not success )


#2

You are sure you connect via https?
Afaik, OctoPrint does not support https at this time, just http.


#3

checking my bookmark
Yeah it’s HTTP://.

Still not found. My iphone found it either Http and Https. Weird!


#4

Really wired. I tried on my iPhone and https was denied...
Anyhow, that's not reason you do not get connected to your PC.

Try this: instead of connecting with http://octopi.local just use octopi.local

If that does not work try a ping:
Open the command processor (terminal) by typing cmd into the windows command line.
Then the processor opens. There type in: ping octopi.local.
You should given back the response times.


#5

I believe that the error may be that a piece of software named bonjour is installed on your pc but it is installed on your iPhone. In that case, try looking up nmap on the app store. There may or may not be a tool to list out all the ip's of all the devices on your local network. I personally use android so i don't know. The tool on android is called PingTools if that helps. You need to connect with a number instead of octopi.local and that number is usually something along the lines of "192.168.x.x" with x standing in for a number assigned by your router.


#6

Ping is working


#7

So your PC has connection to the OctoPrint server.
In this case, ping gives back the IP6 address, we need the IP4 address.
As @fffffgggg54 suggested, you can seek your local network.
For iPhone there are network tools: e.g. Fing and Net Analyzer. They seek your local network and give the IP4 addresses of the devices in your network.
You also may get the IP4 address of OctoPrint from your router.
When you found out the IP4 address of your OctoPrint server, you may can login to the web front end with that address.


#8

I am in!
Ip number solve the problem. Good job everyone :):grin:


#9

You shouldn't have to use the IP address to get to your printer.


#10

Whoa. This one is better!

Now my http://Octopi/ is working! Much better. :slight_smile: