Can not access via Putty or octopi.local but CAN via IP address

What is the problem?
Can not access via Putty or octopi.local but CAN via IP address
What did you already try to solve it?
Tried several fresh images, verifying settings on the sd card, watched the video, lurked on here and tried several suggestions such as verifying that ssh is enabled in the firmware
Logs (syslog, dmesg, ... no logs, no support)
I cant get any logs...
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
raspberry pi 3 b+
windows 10 laptop
a mesh network? I don't know... my isp installed it

I CAN access it with a hardwired monitor and keyboard and I can access octopi with the ip address and have had 3 successful prints; but I am worried that if I keep it going from here I might miss something critical or such.

Did you install the bonjour service?

1 Like

Name resolution hacks

Yes, bonjour is installed.

You might review the Pi's /var/log/syslog and search for Bonjour or Avahi. I had one scenario in which I'd just moved the microSD from one Pi to another and re-introduced it to my wifi network (and DHCP server). The log indicated something like...

yada yada avahi not issuing "octopi" since it's in use, using "octopi-2" instead...

So basically, in this particular scenario if the Avahi (Bonjour) client on the Pi asks the router if it can use & broadcast its hostname as "octopi" the router can technically refuse that request, forcing the client to increment the hostname so that it's unique on the network. Of course, all this happens quietly in the log file if you don't read it so it looks like it's not responding to its name.

Anyway, the link I provided suggests that you reserve a static IP address in your DHCP server for the Pi's mac address.

Reserving that static IP would be through the router correct? Because if that the case the router doesn't see the Pi either. :frowning:

I'm thinking that all this stems from having a mesh network, could that ultimately be the issue?

I didn't see that earlier.

Wifi networks (the router) in infrastructure mode have a DHCP server which issues IP addresses and usually maintains a DNS server to assist with lookups. In many cases it will actively participate in the propagation of hostname broadcast traffic (typical of Avahi) from one segment to another.

Wifi networks in the ad hoc mode is what you'd do in a pinch if you're trying to connect two laptops together to do a demonstration for an audience.