Can not format a SD card with octopi installed on it

What is the problem?
My other problem kept persisting, so I thought to update and start from scratch. I tried flashing the card, but it kept failing. Now I am trying to erase the card completely, but it will not let me. The Boot drive will just not format. And using sudo diskutil eraseDisk FAT32 MYSD MBRFormat /dev/disk2 keeps saying the following

Creating the partition map
Waiting for partitions to activate
Formatting disk2s1 as MS-DOS (FAT32) with name MYSD
Error: -69830: This operation requires an unmounted disk

This is what the card looks like.

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *7.9 GB     disk2
   1:             Windows_FAT_32 boot                    45.2 MB    disk2s1
   2:                      Linux                         7.9 GB     disk2s2

Tried both macOS Disk Utility and diskutil on the command line. But nothing works.

When you burn a now image onto a SD card, there is no need of formatting the card before. During the burn, all formatting information are deleted anyhow.

1 Like

well this is not the case. The etcher will just not burn my card any more. So I need to format it some how, but this also isn't working. All I get is "failed" and all the original data is on the card.

This is all I get.

The error message says what is wrong. You cannot format a mounted filesystem.
If you are booted to the SD card, you cannot format it. If you have booted to something else, and the card is in a reader, Linux probably automounted it. If that is the case, before you format, you have to use "sudo umount /Dev/disk2"
I have never seen a drive in Linux as /Dev/diskxx, so I am not sure what you are using
Best way is to use Windows and download sdcard Formatter

If that fails to format the card, then the card is defective and cannot be used

1 Like

Im on a mac, and tried that program, also with no luck. Unmounting the disk also does nothing.

I can now boot back in my original Octopi image, but it seems very unstable it either tells me

Looks like something went wrong during startup, the server is gone again. You should check octoprint.logs

Which can be found here


Server is offline
The server appears to be offline, at least I'm not getting any response from it. I could not reconnect automatically, but you may try a manual reconnect using the button below.


The OctoPrint server is currently not running

I have the feeling the SD card is just dead.

Etcher should automatically unmount the disk as necessary (but it needs you to provide the correct MacBook administrator password when prompted).

1 Like