Can only acces octoprint on the raspberry pi itself. octoprint on raspbian


#1

I installed octoprint on my Pi 3B today running raspbian. I followed the guide about installing octoprint on raspbian this guide. Everything went good without any errors and the server can be started just fine.

If i go to http://0.0.0.0:5000/ (which is what the guide says) on chromium on the pi itself i can acces the interface just fine. But if i try this on any other pc it can't reach it.

I have already tried every other adress like octopi.local and the local ip of the pi on both the pi itself and other pc's but that doesn't work either. I tried installing HAProxy which is also in the guide. It installed fine and i did everything in the guide but it doens't change anything.

yesterday i tried just flashing an sd card with the octopi image and i got to acces it just fine on my pc. So it's probably nothing on the pc or router end i presume.

I'm running the latest version of everything.


#2

Where does the guide say you should go there? The guide shows that OctoPrint listens on that "address". But 0.0.0.0 is actually sort of a shorthand for "any address that this computer can be reached by".

From the raspberry pi itself, you should be able to access the server at http://127.0.0.1:5000. The 127.0.0.1, also known as localhost, always refers to "this computer itself". So if you would use that same address on - say - your laptop, you instruct your laptop to try to connect to octoprint installed on your laptop. And since you did not (and probably should not) install octoprint on your laptop, this would not work.

You need to find out the ip address that can be used to access your raspberry pi from your main computer.

What is the output of ifconfig, when ran on your raspberry pi?


#3

thanks for the answer!
the guid simply said "*Running on http://0.0.0.0:5000/" and since i am kindoff a noob when it comes to networks and ip stuff and it went to the page i figured that was the new "ip".
As you said i can get access to the server at http://127.0.0.1:5000 on the pi.

The output of ifconfig is the following:

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

        ether b8:27:eb:1e:54:c7  txqueuelen 1000  (Ethernet)

        RX packets 0  bytes 0 (0.0 B)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 0  bytes 0 (0.0 B)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536

        inet 127.0.0.1  netmask 255.0.0.0

        inet6 ::1  prefixlen 128  scopeid 0x10<host>

        loop  txqueuelen 1000  (Local Loopback)

        RX packets 413  bytes 3100037 (2.9 MiB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 413  bytes 3100037 (2.9 MiB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

        inet 192.168.1.21  netmask 255.255.255.0  broadcast 192.168.1.255

        inet6 fe80::f93d:bcb9:fe5f:a550  prefixlen 64  scopeid 0x20<link>

        inet6 2a02:a03f:4a83:b900:19cf:7bb4:ce04:25ab  prefixlen 64  scopeid 0x0<global>

        ether b8:27:eb:4b:01:92  txqueuelen 1000  (Ethernet)

        RX packets 1357  bytes 573689 (560.2 KiB)

        RX errors 0  dropped 73  overruns 0  frame 0

        TX packets 1002  bytes 206327 (201.4 KiB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Would the ip adress that im looking for be a local ip adress something like 192.168.1.21 (which i tried)? or would it be a "real" ip adress?
ps: i am using the pi with wifi.


#4

Try http://192.168.1.21:5000