Can only connect to Pi through PuTTY or cell phone with WiFi turned on

Hello everyone: I recently picked up a Raspberry Pi and jumped through the neccessary hoops to get Octopi setup on it. Problem I'm having is I cannot access Octoprint through a web browser, using either the correct Ip or .local thing. Weird thing is even though it the Ip address shows as connected on my router,I get nothing at all with eithernet cable or WiFi over web browser yet I can get in using Ip address with PuTTY. I can and have gained access and actually set up and remotely controlled one of my printers through my phones browser using ip address, BUT....Only when I have phones WiFi turned on and am in range.
**What did you already try to solve it?**I've tried literally everything I can think of or find on the internet with no result. I can ping my router from the Pi and ping the Pi from my router and computer(s) but cannot ping my computers from the Pi. I do have a double NAT problem caused by my internet providers router assigning different translation than my wireless router which is downstream. If I can get Spectrums router set up in "bridge" or "passthrough" mode would that solve my connection issues? Has anyone experienced similar? Thanks in advance...

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Hello @BillMeLater!

So, what browser are you using? Are scripts activated?
Have you entered the IP/octopi.local without www. in front of it (browsers commonly autocorrect this). So enter: http://octopi.local or http://"IP-address"
Ethernet connection and WiFi will have different IP addresses.

Sounds like your router is your problem.

  • Pi can ping the router
  • router can ping the Pi
  • workstation can ping the router and vice versa
  • workstation can't ping the Pi

So the "routing" is all screwed up and your home network with wifi is dysfunctional, to be brutally honest. You haven't mentioned what OS is on your workstation (probably Windows since you said "PuTTY") and it probably has a software firewall added to all this for extra confusion.

Have you considered adding an Ethernet crossover cable from your laptop to your Pi?

Correct. My router log shows both Lan and Wlan Ip s along with my Hostname so I know it's getting that far. I suspect it's router related have yet to figure out exactly what. I have tried several different browser/computer/login combos and the only thing that will open Octoprint Gui is my cell phone and then only when connected to my router via WiFi. I have 4 different Widows machines running Opera, Firefox, Chrome and whatever crap comes with 10 these days. None of them work. I'm pretty sure it's due to my Spectrum router and personal router which is downstream both throwing firewalls up.

My current biggest issue is obtaining access to the router supplied by Spectrum. Without that I can't set it to passthrough, essentially turning it into a gateway and hopefully solving double NAT situation. I actually did try entering my Pi Ip into the DMZ on my router (firewall bypass mode), unfortunately that was also a dead end. Might bring the Pi itself over to a buddies house just to see if I can access Gui through his Wifi. At least that would tell me more about where the problem lies? Any ideas anyone?

When I do talks out at venues I use an Ethernet crossover cable straight from the Pi to my laptop.

I do have a laptop and have yet to try that. At the very least it'd give me a bit more screen area than my phone. I have fairly severe vision problems so every bit of screen area helps.