🇺🇦 We stand with Ukraine! 🇺🇦

Can SSH to octopi.local but https://octopi.local/ cannot connect

What is the problem?
I cannot connect to octopi.local via the web interface. The background is I just unpacked my printer after a year of being in the box, when I did so, octopi worked fine, but warned me to upgrade from python2. After imaging the latest version using the raspberry pi imager, the problem occured (before I got a chance to restore backup)

What did you already try to solve it?
Made sure the wifi locale was correct. Set the IP address to 192.168.68.250. Can ssh to octopi.local and ping octopi.local without issue.

Logs (syslog, dmesg, ... no logs, no support)
Can't access logs, but here's the ping
ping octopi.local
PING octopi.local (192.168.68.250): 56 data bytes
64 bytes from 192.168.68.250: icmp_seq=0 ttl=64 time=8.612 ms

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I'm using the TP-link mesh network system. As stated above, this worked fine prior to upgrading.

Hello,
did you try a different browser? The browser might be configured to only use some other name server (DNS) or go via a proxy so that *.local won't resolve

Thanks, I tried 2 more browsers with the same result unfortunately.

You say you can SSH into the RPi using octopi.local and you can ping octopi.local so it would seem that the browser should work as well. Try using https:// instead of the name. Also try https://:5000.

If you have an anti-virus / internet security suite installed on the system you are attempting to connect from, temporarily turn it off and try again.

Tell us more (i.e. answer all the questions in "Additional information about your network (Hardware you are trying to connect to , hardware you are trying to connect from , router, access point, used operating systems, ...)".

I'm not sure what you mean by trying https://, you mean in the browser? I tried using the ip or the hostname with identical results (unable to connect to server).
Re hardware:
I'm connecting using a mac. I also tried using OctoPod on my iphone with same results. The network is the Deco mesh network system by TP-Link.
The pi is Raspberry Pi 3 Model B Rev 1.2
Again, this worked fine before updating. Is it possible there's an issue with the Pi OS? I'm using raspi-config version 20211111

If you can SSH into the RPi, then the network is working. One of two things is preventing you from connecting with a browser, either the OctoPrint server isn't running or something like a web proxy is preventing the connection.

First, what is the exact error you get in the browser? Second, see this response, Octoprint server appears broken? - #2 by foosel. Execute the commands as shown and post the results along with the log file (which you can copy using scp, using scp on a Mac is an exercise left to the reader).

Thanks for your patience here.
Here is the browser error:

Unable to connect

Firefox can’t establish a connection to the server at octopi.local.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

From the referenced response, we may be getting closer, there is no ~/oprint directory

> source ~/oprint/bin/activate
> -bash: /home/pi/oprint/bin/activate: No such file or directory

What image did you flash? What does cat /etc/octopi_version say?

I'm following the instructions here: OctoPrint.org - Download & Setup OctoPrint
I've used all the defaults except for locale

cat: /etc/octopi_version: No such file or directory

Something must have gone wrong, this is not an OctoPi image you flashed there or there would be that file.

OMG, it was the wrong Pi OS (I used the default rather than finding octopi) :grimacing:. I owe you all. Donating now.

3 Likes