Octoprint server appears broken?

What is the problem?
Unable to start Octoprint.

Everything started up fine, and an update was started from the server front-end in the webapp. After that, it hasn't worked at all. I can connect in putty but the octoprint service appears stuck in active (exited) and the logfile will no longer update.

What did you already try to solve it?
I ran ps -ef | grep -i octoprint | grep -i python (which returned nothing) and looked at the logfiles. I also attempted to restart octoprint using sudo service octoprint restart.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

pi@'s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Mar 27 20:56:41 2018 from

Access OctoPrint from a web browser on your network by navigating to any of:


https is also available, with a self-signed certificate.
OctoPrint version : 1.3.6
OctoPi version    : 0.14.0

pi@octopi:~ $ sudo nano ~/.octoprint/logs/octoprint.log
  GNU nano 2.2.6                             File: /home/pi/.octoprint/logs/octoprint.log

2018-03-27 20:23:57,350 - octoprint.server - INFO - --- Log roll over detected ---------------------------------------------------
2018-03-27 20:23:57,350 - octoprint.server - INFO - OctoPrint 1.3.4 (master branch)
2018-03-27 20:23:57,351 - octoprint.plugin.core - INFO - 7 plugin(s) registered with the system:
|  Announcement Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/announcements
|  Core Wizard (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/corewizard
|  CuraEngine (<= 15.04) (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/cura
|  Discovery (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/discovery
|  Plugin Manager (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/pluginmanager
|  Software Update (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/softwareupdate
|  Virtual Printer (bundled) = /home/pi/oprint/lib/python2.7/site-packages/OctoPrint-1.3.4-py2.7.egg/octoprint/plugins/virtual_printer
2018-03-27 20:23:57,351 - octoprint.server - INFO - ------------------------------------------------------------------------------
2018-03-27 20:23:57,348 - octoprint.server.util.flask.PreemptiveCache - INFO - Adding entry for / and {'query_string': 'l10n=en', 'path': u'/', '_count':$
2018-03-27 20:24:06,105 - octoprint.server.util.sockjs - INFO - New connection from client:
2018-03-27 20:24:50,016 - octoprint.plugins.announcements - INFO - Loaded channel _important from http://octoprint.org/feeds/important.xml in 1.2s
2018-03-27 20:24:52,010 - octoprint.plugins.announcements - INFO - Loaded channel _releases from http://octoprint.org/feeds/releases.xml in 1.5s
2018-03-27 20:24:53,150 - octoprint.plugins.announcements - INFO - Loaded channel _blog from http://octoprint.org/feeds/octoblog.xml in 1.0s
2018-03-27 20:24:54,328 - octoprint.plugins.announcements - INFO - Loaded channel _plugins from http://plugins.octoprint.org/feed.xml in 1.1s
2018-03-27 20:24:55,484 - octoprint.plugins.announcements - INFO - Loaded channel _octopi from http://octoprint.org/feeds/octopi.xml in 1.0s
2018-03-27 20:24:56,452 - octoprint.plugins.softwareupdate - INFO - Saved version cache to disk
2018-03-27 20:33:08,244 - octoprint.server.util.sockjs - INFO - Client connection closed:
2018-03-27 20:33:08,803 - octoprint.server.util.sockjs - INFO - New connection from client:
2018-03-27 20:33:14,260 - octoprint.plugins.softwareupdate - INFO - Starting update of octoprint to 1.3.6...
pi@octopi:~ $ sudo service octoprint status
‚óŹ octoprint.service - LSB: OctoPrint daemon
   Loaded: loaded (/etc/init.d/octoprint)
   Active: active (exited) since Tue 2018-03-27 21:30:23 EDT; 3min 33s ago
  Process: 523 ExecStart=/etc/init.d/octoprint start (code=exited, status=0/SUCCESS)

Mar 27 21:30:23 octopi octoprint[523]: Starting OctoPrint Daemon: OctoPrint.
Mar 27 21:30:23 octopi systemd[1]: Started LSB: OctoPrint daemon.

First of all: stop putting sudo in front of commands unless you really need to execute them as super user. You can and will break things that way! There's no need for sudo to read OctoPrint's log.

You haven't said what happens when you try to access OctoPrint from your browser but I assume you are seeing that "The OctoPrint server is currently not running" troubleshooting page? If not, please specify what you see (best make a screen shot).

Execute these three commands please and report back on what output that produces. Use the </> button in your post toolbar to format things like that output so it actually stays readable.

sudo service octoprint stop
source ~/oprint/bin/activate
octoprint serve

Also please upload your octoprint.log - I have no idea if that odd line at the end of your output up there is a result of using nano or if that is actually in there, and if it's the latter it sounds like file system corruption.

1 Like