Can SSH via Wifi, but can't connect to Octopi in browser


#1

Hi all,
I'm attempting to setup Octoprint for the first time, using the Octopi 0.15.1 image, and Octoprint 1.3.8

I've successfully installed the image to a Raspberry Pi 3, and can connect via SSH to the device, and issue commands from the command line successfully.

However, when I try to connect via a web browser to either the IP (the same one I can successfully SSH to) or to octopi.local, it fails to connect (spins). If I connect an ethernet cable, then I can connect successfully to the Octopi interface through the browser using either octopi.local or the IP address.

I've also tried safe mode to no avail.

Including some various things below which may or may not be helpful (will include log separately - it won't let me post it as a new user since it complains about posting "more than two links")

Thanks for the assistance!

Scott


wget localhost from SSH - returns index.html which looks like the correct Octoprint home page


ps aux | grep octo

pi       17282 18.9  5.6 186580 51028 ?        Sl   14:44   0:42 /home/pi/oprint/bin/python2 /home/pi/oprint/bin/octoprint serve --host=127.0.0.1 --port=5000

pi@octopi:~/.octoprint $ sudo netstat -tulpen | grep haproxy
[sudo] password for pi:
tcp6       0      0 :::80                   :::*                    LISTEN      0          11680      578/haproxy
tcp6       0      0 :::443                  :::*                    LISTEN      0          11681      578/haproxy
udp        0      0 0.0.0.0:57550           0.0.0.0:*                           0          11682      577/haproxy-master


#2

octoprint.log:

octoprint.log:

2018-07-07 14:45:03,464 - octoprint.events - INFO - Processing startup event, this is our first event
2018-07-07 14:45:03,465 - octoprint.events - INFO - Adding 0 events to queue that were held back before startup event
2018-07-07 14:45:03,466 - octoprint.filemanager - INFO - Adding backlog items from all storage types to analysis queue...
2018-07-07 14:45:03,471 - octoprint.filemanager - INFO - Added 0 items from storage type "local" to analysis queue
2018-07-07 14:45:03,486 - octoprint.plugins.discovery - INFO - Registered OctoPrint instance on octopi for _http._tcp
2018-07-07 14:45:03,497 - octoprint.plugins.discovery - INFO - Registered OctoPrint instance on octopi for _octoprint._tcp
2018-07-07 14:45:03,500 - octoprint.server - INFO - Listening on http://127.0.0.1:5000
2018-07-07 14:45:03,501 - octoprint.server - INFO - Server started successfully in safe mode as requested from config, removing flag
2018-07-07 14:45:03,509 - octoprint.plugins.discovery - INFO - Registered OctoPrint instance on octopi for SSDP
2018-07-07 14:45:03,641 - octoprint.plugins.pluginmanager - INFO - Loaded plugin repository data from disk, was still valid
2018-07-07 14:45:04,005 - octoprint.plugins.pluginmanager - INFO - Loaded notice data from disk, was still valid
2018-07-07 14:45:04,043 - octoprint.server.preemptive_cache - INFO - Preemptively caching / (ui _default) for {'query_string': 'l10n=en', 'path': '/',
 'base_url': 'http://192.168.1.39/'}
2018-07-07 14:45:21,785 - octoprint.server.preemptive_cache - INFO - ... done in 17.74s
2018-07-07 14:45:21,786 - octoprint.server.preemptive_cache - INFO - Preemptively caching / (ui _default) for {'query_string': 'l10n=en', 'path': '/',
 'base_url': 'http://octopi.local/'}
2018-07-07 14:45:26,775 - octoprint.server.preemptive_cache - INFO - ... done in 4.99s
2018-07-07 14:45:26,776 - octoprint.server.preemptive_cache - INFO - Preemptively caching / (ui _default) for {'query_string': 'l10n=en', 'path': '/',
 'base_url': 'http://octopi/'}
2018-07-07 14:45:31,812 - octoprint.server.preemptive_cache - INFO - ... done in 5.04s
2018-07-07 14:45:31,813 - octoprint.server.preemptive_cache - INFO - Preemptively caching / (ui _default) for {'query_string': 'l10n=en', 'path': '/',
 'base_url': 'https://192.168.1.39/'}
2018-07-07 14:45:36,925 - octoprint.server.preemptive_cache - INFO - ... done in 5.11s

#3

I figured out the issue - the wireless connection for the PC I was trying to connect with was down (it was still connected to the network via ethernet), so it couldn't access the wifi network of the RPi.

Sorry if anyone wasted any time on this!

Thanks anyway!

Scott