Can´t use update Octopi, Plugins or pip

At some point the update system stopped working. The update requester is shown and when I click update I get thes error "Update not started - Update already active?". It is the same for updating Octoprint itself, a plugin or pip. If I use the shell I can update everything with pip without a problem. The only thing the log is showing is "2021-01-24 20:20:17,271 - tornado.access - WARNING - 409 POST /plugin/softwareupdate/update (::ffff: 34.73ms" and I don´t even know wether this is really connected to the problem.
Before that update via web interface worked fine.octoprint(1).log (118.2 KB)

Not quite sure whats wrong - logs would help us :slight_smile:

I attached the log file. But as I said, there is nothing in there around the error...

The easiest thing to do would be to backup your config and reflash your micro sd card and then restore your backup of your settings. It's possible that an update got interrupted and didn't complete so the system thinks it's still in progress.

Do you know where is this stored? Is there a way to reset that flag?

Hello @Twilek!

You have this issue:

2021-01-24 20:18:52,572 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

You may have to get a better power source first.

My Pi is connected via stepdown converter to the powersupply of my prusa. There should be enought juice really.

Is that connected to the 5v GPIO Pins? You should never power a Pi like that. There is no voltage or current protection on the GPIO pins. That's a great way to fry your Pi. The Micro or C USB power port has a fuse which will protect your pi for current and voltage spikes. If you fry your 3.3v regulator, your pi will be worthless. I only mention this because I too didn't think this was a "thing" until I fried a pi doing that. :slight_smile:

Also, unless you have a quality step-down regulator that can provide at least 2.5A of juice, you will still get this warning . It's not whether the printer has enough power it's whether the step-down converter can deliver enough juice. Most of the cheap ones online are only rated for 1 or 2 amps peak. That means they can only supply 0.75 or 1.5 amps continuously. (Rule of 75% capacity). So, you would need a buck converter that can support 3A to safely power a Pi with one.


No. As i said, the easiest thing to do would be to reimage your SD card. Your backup will save all your settings.

The Step Down converter is rated for 5 Amps and automatic adaption of input voltage (no manual adjustment necessary) and cost almost 10 Euro. So I hope I didn´t get swindled and this is a quality device. But I will have to think about not having a fuse there.
Maybe I will go down the reflash route. Right now it is only a minor nuissance as I can install updates via the shell in a minute. I just wondered wether it was a simple problem like resettig some config value or something similar. Thanks for the info.

Althought this now is quickly getting of topic maybe I can tap your knowledge again. I did a "vcgencmd get_throttled" and got a "throttled=0x50005". If I interpret that correctly it means that it was throttled at some point but more importantly it IS throttled at that moment. A "vcgencmd measure_clock arm" gives "frequency(48)=600064000" which is 0,6 Ghz?! If I am reading this correctly the CPU of my Pi is running at 50% speed? Or am I missing something here? Interestingly Octoprint doesn´t show the undervoltage icon and subjectively runs fine....

Yes. That is EXACTLY what that means. So, I don't know if I would trust your step-down converter to be delivering the needed 5.1v. It's also possible that you are losing a lot of voltage in your wiring. If you are using Dupont cables, those are usually 26 or 28 gauge wire. 28 gauge wire carrying 3.1 A at 5v will lose approximately 0.8v or 16 % of the total voltage. That means that if you have 2 feet of wire between your printer and your pi, your pi is only getting 4.2v. So, if your buck converter is closer to the printer than the pi, I would move it so that it delivers 12 volt to the buck converter close to the pi and the voltage then travels only a short distance to the Pi.

My Pi sits 3 centimeters below the Einsy board. I really use Dupont Cables but they are only approximately 5 cm long. Strange.
I had another thought by the way. What if Ocotprint for the some reason can´t execute shell commands anymore?! Then the update wouldn´t work because it can´t run pip and the undervoltage won´t show because it can´t run vcgencmd.

Even 1 foot of 28 gauge dupont connectors are going to drop the voltage by 0.4v. You're talking 3.1A here through 28 gauge wire. You're going to lose a LOT in the transfer regardless of the length. You have to use thicker wire. Or, I would suggest getting something like this:

This will deliver the needed voltage directly to the Pi power socket rather than the GPIO. Safer and able to deliver much more power since it's not using a dupont connector.

There are 24v versions if that's the power that your printer uses.

Or, if you have an old USB cable, you can try to wire that directly to your current Buck converter and see if the warning goes away. Just make sure you use a good PD (power delivery) rated cable.

Honestly, bin the converter, people who say they use these are way more likely to have issues. Get a proper power supply, power it through the USB port not the GPIO pins. Dupont connectors don't have bad contact and can introduce high resistance, which drops the voltage. If it falls below ~4.65V internally on the Pi, then it will complain.

And don't forget, as you have shown, that no matter how good you think your power supply is if the Pi is complaining then the system is throttled, which causes instability and could be the cause of any number of random problems. Get a proper power supply first, then if you still have issues at least you know it is not the power supply, and the Pi will be running at full tilt again, not 50%.

I wanted to use the internal power connection to reduce the amount of cabling running out of the printer. But you convinced me that that maybe wasn´t the best option safetywise. So I have removed the whole Stepdown converter contraption and put on an external power supply. What can I say 1,2Ghz CPU clock, no throttling AND drumroll please.... The update startet working again as well as if by magic. So I guess I have one more ugly cable now but a working and safer printer for it. Seems like a trade off I can live with ;-). Thanks for the tremendous help guys!

1 Like

I have gone through the same thing on many Pi projects. In the end, using a dedicated Pi power supply fixes a lot of problems. Now, if you powered it through the USB C port from your buck converter, I'm willing to bet it would work too. So, you might be able to eliminate one cord that way. But I'm glad you got everything working again. :grin:

Well after I turned the printer back on I noticed that the serial connection doesn´t work reliably anymore . I completely exchanged the wires in case something was bent or broken, but it continued totransmit some data, but also a lot of garbage. As the CPU is working full power now is there something that might make it difficult for the timing of the UART or have I fried something inadvertantly? Connecting the printer via USB works just fine. I have connected RX and TX and GPIO 22 and 23. That setup worked flawlessly before. Sigh...

I believe the GPIO for the built in serial connection are pins 8 and 10 GPIO 14 and 15.

I connected it like this

There is data coming throught. But most of it is garbled. The same wiring worked before. As I said, I replaced the wires.