Cancel upload causes stepper motors to continually move to max and bang


#1

What is the problem?
Maker Select / Wanhao Duplicator i3
When uploading a file to the printer's SD Card and then pressing the Cancel button the x and y steppers move and bang against the frame.

What did you already try to solve it?
Not press cancel... Tried different baud rates. Does not seem to happen at 1,000,000 baud.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint 1.3.9
OctoPi 0.15.1
Maker Select / Wanhao Duplicator i3 - unknown firmware version (stock)
Will get logs if this isn't common/known behavior.

If this is a known issue then I wonder if maybe I can just put in a hook to wait a millisecond and disable the steppers. If not known then I'll get the terminal log to see what's happening (printing right now).


#2

Hi!
The only Cancel button I know about is that one that refers to printing.
So as long I did not start printing, I can not press the Cancel button.
And printing can only be started after uploading the gcode file to the SD card and even a 67kb gcode file takes a long long time, several minutes (I just try to to get to your problem)

You may have a reason to upload to the SD card via OctoPrint, but there are faster methods.

I don't know if this is a known issue, but most users direcly upload to the OctoPrint memory and let OctoPrint do the print.

I hope I did not misunderstand you...


#3

Yeah, I'm not likely to upload to SD card. It's just too time consuming even on high 1mil baud. I was just testing it out.

Octoprint definitely let's me cancel the upload. It's the same button for canceling the print. Drag and drop a file to the right hand side of the web interface. The page shows "upload to SD card" then in the area where the print status typically is you see the status of the upload. The cancel button is there.

Press it before the upload completes and stepper motors activate and increase position until they bang on the frame. Wouldn't be a problem if they homed instead as there are stop sensors in that direction.


#4

Ok, I give it another try...


#5

So I tried it again. Result:
The firmware (Prusa i3 MK2MM, 3.1.0) gives an error and OctoPrint cuts off the connection to the printer and instead the file is saved to the OctoPrint memory.


#6

That's pretty much the same for me. What I'm wondering is why the steppers start going. Anyway, I'm likely to always print from the pi's card, so not a big deal just thought I might start a thread here to see if there's a workaround in case someone else runs in to the issue.


#7

So maybe the firmware in the Duplicator reacts that way instead of giving an error message.
Maybe someone else knows more...


#8

Yeah, I'm probably going to update the firmware soon. I'll try to remember to report back here if that changes the cancel SD transfer behavior.


#9

Sounds like the firmware freaks out if an SD transfer is cancelled. Can you try it with other host software that allows sd transfer? Sadly I don't know which other host software might have that ability, perhaps repetier host?