Cancelling job seems never ending

What is the problem?
With respect to my previous post about temperature errors with gcode is uploaded from internet, I also face additional issue.
Whenever I try to cancel a job, the octoprint interface is properly updated and seems to start cancellation.
However, it never finishes. Also from what I see, the temperature does not does down.

What did you already try to solve it?
Physical shutdown of the printer ! The power outlet of the printer is controlled from my Domoticz server !

Additional information about your setup
OctoPrint version 1.3.11,
OctoPi version: 0.60,
printer: Alfawise U30, latest firmware,
octoprint.log :octoprint.log (15.5 KB)

The printer is in the process of heating the bed or the hot end. It can not respond to the cancel code until it finishes what it is doing (heating up the bed or the hot end.) If you are in a hurry, after you cancel, use the disconnect button on the interface, once disconnected, power cycle the printer so it stops heating, then reconnect. This is not a bug, this is a serial connections so nothing can happen until first code is done.

1 Like

Thanks. This makes sense. One command after the other.
The pity in my case, is it won't finish. 400Β°c would never be reached!
At least now, I now it was useless to wait in such case.

You can try sending an M108 - if the firmware has EMERGENCY_PARSER enabled (at least for Marlin) it should stop waiting for heating and allow the cancel to proceed.

Note that OctoPrint 1.3.11+ will even automatically send M108 on cancel if said capability is reported by the firmware (and you haven't disabled that behaviour).

That is a very much appreciated addition to OctoPrint. Thank you very much!

I found a little tric
add in the slicer start code for example

M140 S30 ; bed
M190 S30 ; bed
M104 S80 ; hot end
M109 S80 ; hot end

Often I cancel my print just after starting.
And then I need to wait that the temperature is done.
When you set the first heat to on lower level you the cancel heating after 20sec for this values
You can change this higher or lower if you want.
I tries also to make a few heating settings in serial but its not work correctly.
The idea is to make 5 or more steps off temperature an after eatch step the cancel should works.
For the moment only the highest value stop the print.
I will make some tests to find a solution


Hello @Berni !

This is what Smart Preheat does.

Smart preheat is installed on my Octoprint (Version 1.6.0)
But the cancel works only when the max temp is reached an not at the fisrt step off temperatur.
I made a chec.
Cancel became activ only when the print temp is reached

Ooops, I mixed it up with: Set And Wait

Emergency parser is probably still the preferred way to go here, since it doesn't require complex setup whenever you want to try and change temperatures.