Cannot Access OctoPi via IPv6 (via DS-Lite, FritzBox)

What is the problem?
Since I got faster Internet, I no longer have a public IPv4 adress (IPv6 only, aka DS-Lite). My FritzBox Router forwards port 80 of the octopi to the open web. Visting the URL (see below) leads to a connection timeout.

What did you already try to solve it?
Octopi is accessible within my local Wifi without issues, but I want to have it on the open web (I am aware of potential risks, and also workarounds like VPN or third party octopi plugins/cloud services).
FritzBox offers a DYNDNS like service, which I have enabled, that gives my local network an open web URL like I used to be able to use this to access octopi from the web with identical configuration, but since moving to ipv6 this no longer works, despite my fritzbox showing it is enabled to use ipv6 for the port forwarding. Router and Octopi were rebooted multiple times already.

Logs (syslog, dmesg, ... no logs, no support)
Not sure which Octoprint logs are relevant for this, but my octoprint confirms it is able to access the internet (updates etc. work fine).

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Multitude of webbrowsers, over the same internet connection of the router on a pc as well as from android mobile phones online via LTE, all show connection timeout.

First, please tell me you have some security on your port forwarding. You do not escape this lecture because you have used a way to make a random URL, bots on the internet will find servers that don't even have a domain assigned. Case in point, OctoPrint - Shodan Search

Use additional security. The OctoPrint login screen is not good enough to protect you.

The log for you to look at is probably the haproxy log, /var/log/haproxy.log. There may be an issue with either haproxy and IPv6 or your Pi and IPv6