Cannot access pi@octopi from monitor and keyboard plugged into raspberry pi

What is the problem?

When i plug a monitor and keyboard into my raspberry pi 400, i cannot access the command line "pi@octopi:" for octo pi. I can only access it over SSH

What did you already try to solve it?

This use to work, before i updated and installed octodash

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36 Edg/97.0.1072.62
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1800
env.hardware.ram: 3971678208
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 400 Rev 1.0
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.7.3
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version: 1.7.3,
OctoPi version: 0.18.0
printer Ender 5 Plus
firmware: ??
browser: Chrome
operating system: win 10

What do you see on the monitor?

Here is a picture of my screen

It looks like the desktop environment that is configured to auto-start is not (or no longer) working. In an ssh session, run sudo raspi-config and set the autostart option not to load the desktop.

So that fixed it, but it broke octodash. Octodash will no longer load with B1 auto-start option selected. They only way to get octodash to load is to use 1 System Options -> S5 Boot / Auto Login -> B2 Console Autologin; but then i lose command line. Guess i just have to select which one i want to be able to use.

Try CTRL+ALT+[F1-F8[

CTRL+ALT F3 got me to command. Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.