Cannot check for throttling

What is the problem?

since the last 2 Updates i have sporadic crashes and freezes. So i check the log-files:
only one line in the log file was noticeable:
octoprint.plugins.pi_support - WARNING - Fetching the current throttle state via "/usr/bin/vcgencmd get_throttled" doesn't work.
and recently after the last Update i have a pop-up-message with a not to this problem:

And the OP only crashes if i print via OP. If i print from SD-Card i have no crashes, and can watch the print with the cam for hours. noting happens. SO i guess theres a problem with the PI, the OS or OP. But no clue, because theres no nice logfile-info.

What did you already try to solve it?

deactivation of not needed plugins

Have you tried running in safe mode?

not yet, its a 8 hrs print

Did running in safe mode solve the problem?


Systeminfo Bundle

[|attachment](upload:// (14.3 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OP Version 1.7.3
Octopi: Version 1.0.0, running on Raspberry Pi 4 Model B Rev 1.4
printer is a Ender v3 Pro
FW ist Marlin
Browser Google Chrome

Did the same issues occur on the stable OctoPi build? Since you are testing a new OS image here it would make sense to rule out that being the problem.

Hello Charlie,

thank the for he requst.
so I know, i did not change anything and have no clue since when this version is on my system.
Normaly i only check for updates and let them install. this is no conscious adaptation i did.
could it be, that this version was active from the start of using OP?

The OctoPi 1.0.0 release candidate was only published a couple of days ago, so if you have been using 1.0.0 for longer than that then you must have installed a development nightly build at some point. I have no idea when you would have done that. You also have the 64 bit variant of it, which is different than the 32 bit one and may have more issues. I would recommend using the stable 0.18 to test with.

1 Like

so this is a total new installation?

As @Charlie_Powell said: It's a release candidate and quite new.

Yes, ok, i see that, but do i need a total new installation of the image? Ans what Image to use best, please?

The last stable version is 0.18.0. And yes, you have to install it new again.

i did a hole new-Install - but use the backup. After reboot i got a red popup saying "low voltage warning".
Why this? the power-supply did not change.

Your Pi was throttled probably the whole time, but it couldn't check because vcgencmd wasn't working :wink: Now that works you get the warning.

after a messurment i fixed this from 4.6 to 5.1 volts - after a reboot, this warning ist gone now.

I am having the same issue.

OP Version 1.7.3
Octopi: Version 1.0.0, running on Raspberry Pi 4 Model B Rev 1.1
Printer is an Ender 3v2
FW is JyersUI 2.0.1

I am able to run the stable release just fine, but like you after installing the OctoPi 1.0.0 Release candidate I get the same warning.

as i did, you may change back to stable then.

Installed Version 1.0.0, running on Raspberry Pi 3 Model B Plus Rev 1.3 , USB camera not working anymore. Applied "" Now get message at startup

Cannot check for throttling

OctoPrint cannot check for throttling situations reported by your Pi. vcgencmd doesn't work as expected. Make sure the system user OctoPrint is running under is a member of the "video" group.

Also tried to install / to address USB Camera - Failed

2022-03-05 12:55:15,776 > Processing /tmp/tmpawo8juhy/
2022-03-05 12:55:15,777 > Preparing metadata ( started

Put previous SD card in, rebooted, all is fine. (130.6 KB)

Hello @Monte !

You are aware, that OctoPi 1.0.0 is a release candidate?

I had the same issues. I don't know too much on what to do, I just originally followed the instructions given when I had to upgrade from a previous version that wasn't using the latest python. So I guess I will have to find directions on how to go back to a different version.

Same problem


OctoPrint 1.7.3
Python 3.7.3
OctoPi 0.18.0

I checked and my Pi User is in the video group. rebooted, updated debian, no change.

What happens when you run vcgencmd get_throttled when you are logged in as pi?

To anyone getting this message on OctoPi 1.0.0, especially 64bit

This is a known issue on the OctoPi release candidate and will be fixed in the next one, please stop reporting this issue here. Only report a problem if you are seeing it with the stable OctoPi 0.18.0.

# sudo -u pi vcgencmd get_throttled

And I am running stable 0.18.0