Cannot connect anymore to octopi via wifi

What is the problem?
my octopi is not reachable via wifi, i cannot use cable at the moment because of tecnical problems

What did you already try to solve it?
i'm almost blank on linux, tried to power off and on, reboot. i can't access the network via ethernet because my router have all the ethernet ports not working

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
how can i attach log if i cannot connect anymore to octopi?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
octopi latest version , with touch ui and auto shutdown plugins.
i can navigate via the touchscreen connected to raspberry but it autoboot to the touchui interface, cannot get the prompt to type commands, but any other way to connect it fail.
i noticed that the "news" windows do not show anymore, last time i selected "later" so it should reappear again, but it doesn't, probably it do not have access to the internet.
i checked on router connected device list and octopi is showed with address
if i ping it, windows report that the destination host is not reachable.

How do you try to connect? Do you use an explicit ip-address or a symbolic name like octopi.local?

hello yes i tried to connect directly to ip address using Putty, but it can't connect. usually i was able to connect to it using "octopi" as name (without ".local") but it doesn't work neither.
actually i tried to ping all address from 2 to 255 (without success) in case the router display but the address maybe is not updated and the octopi have another address i do not know.

I assume the router is also the DHCP-server. Does it has information about what ip is given to what hardware-address? In my router there is a list where it shows the ip-addresses and (for me mysteriously) the name "octopi" (I didn't know a DHCP-client sends a name).

yes, when the raspberry pi is powered the router show "octopi -" with a green mark near the name in the list of connected devices
if i turn off the raspberry, the ip address disappear and the mark that was green turn grey
so raspberry somehow connect to router, and the router dhcp assign the address (it usually assign same adresses to same devices connected, for example my pc is always

This is mysterious.

I don't really have a educated guess what it may be.

A few directions to investigate:

What does traceroute (I don't use Windows, I assume you are using, so don't know how to do that there) say?

Other devices on the same wifi-ap are working?

Maybe it's the arp-cache. Try to clear it.

Have you rebooted your pc? (takes also care of clearing the arp-cache :wink: )

Ok, i solved thank of a friend that addressed me to the solution
ofcourse is not software related, nor hardware related as one could normally think
guess what? is the POWER CABLE!
yes that annoying cable i changed so many times trying to get rid of that lightning symbol.
with this one raspberry was no more displaying the lightning symbol, but ofcoure it can not be able to use the wifi, with the other cable the octopi works great (but slow) and i can connect without any problems, but with lightning symbol always on screen! :rage:
i think is the time to power it from pin 2,4 and 6