Cannot connect octopi to WEEDO Tina2

What is the problem?

OctoPrint is unable to connect to my Tina2 printer

What did you already try to solve it?

  • Installed the Malyan/Monoprice Connection Fix plugin (recommended here)
  • Built and installed the new (?) CH430 driver (recommended here following this guide)
  • Fresh install of Octoprint OS on Raspberry PI
  • 3 different USB cables

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20240112150047.zip (73.8 KB)

Additional information about your setup

OctoPrint version 1.9.3, OctoPi version Build 2023.10.09.151442, printer WEEDO Tina2, firmware, browser Edge, Safari, operating system Windows 11, macOS

Logs

octoprint-logs.zip (15.1 KB)

Terminal output

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 8 port/baudrate candidates: /dev/ttyUSB0@1000000, /dev/ttyUSB0@115200, /dev/ttyUSB0@250000, /dev/ttyUSB0@230400, /dev/ttyUSB0@57600, /dev/ttyUSB0@38400, /dev/ttyUSB0@19200, /dev/ttyUSB0@9600
Trying port /dev/ttyUSB0, baudrate 1000000
Connecting to port /dev/ttyUSB0, baudrate 1000000
Handshake attempt #1 with timeout 2.0s
Connected to: Serial<id=0xae3975c8, open=True>(port='/dev/ttyUSB0', baudrate=1000000, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 115200
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 250000
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 230400
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 57600
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 38400
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 19200
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Trying port /dev/ttyUSB0, baudrate 9600
Handshake attempt #1 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #2 with timeout 2.0s
Send: N0 M110 N0*125
Handshake attempt #3 with timeout 2.0s
Send: N0 M110 N0*125
Changing monitoring state from "Detecting serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"
Connection closed, closing down monitor

I recommended this for a monoprice printer, but sure testing it doesn't hurt anyone :slight_smile:

Let's test if your Pi recognizes the printer at all.
I see you got a serial USB connection listed in OctoPrint, but I want to make sure it's the printer and that there isn't an obvious issue with the connection.

Log into your pi via ssh then disconnect your printer, run dmesg -w and connect the printer again. If you don't get any outputs try the other cables - if you do get an output post it here

If you need help with ssh connection, follow this guide

username: pi
password: raspberry

Thank you for your help! The Tina2 and MP Cadet are the same machine, just rebranded, from what I can tell and read online. Hence my hope that the plugin would fix it :confused:

The original results from dmesg -w are extremely long, but when I plugged in the printer, these lines starting with 623 popped up. Then I unplugged it again and the lines starting with 687 appeared:

well that looks good so far

is it the wifi or non wifi variant of the printer?

can you check on the screen which firmware is running on the printer? maybe search for an info screen or something

edit:

wait a minute - I found the firmware source code
it seems like it uses an usual baudrate
#define HOST_BAUDRATE 1000000

add this baudrate in the settings an try to connect then

edit2:

lol they also mentioned it in their docs ^^
http://www.weedotina2.com/doku.php?id=octoprint_connect_f152s

Disable or uninstall the monoprice plugin first. Doesn't look like you need it,

1 Like

Sadly, I've tried that as well without luck :frowning:

Here's another attempt with the plugin disabled and the port/baudrate explicitly set.

After it's not able to connect, the printer restarts. So something is happening on the printer side, but it's not responding/connecting.

:man_facepalming:
I was on the wrong wiki page.

I think we're pretty close

looks like your printer is expecting some special W commands
and it seems like the baudrate should be 57600 for some reason

that's what they configured in the source code and I assumed the host baudrate is the one we need

#define HOST_BAUDRATE 		1000000		
	
#define SPARK_BAUDRATE 		57600		

#define WIFI_BAUDRATE		  1000000

check the correct wiki page
http://www.weedotina2.com/doku.php?id=octoprint_connect_tina2

you can do the display plugin stuff later - just let us get the connection working first.

1 Like

Now I remember having tried these W scripts before too. I tried setting those up (as well as the printer profile, but that shouldn't matter at this point) and connecting using 1000000 baud rate as well as 57600 but still the same error. I didn't bother with the plugins after the script updates.

And both baudrates again with the monoprice plugin?

1 Like

No change. I'm at a loss - I haven't seen any other guides or recommendations anywhere online.

Honestly I'm also out of ideas :confused:

I also wasn't able to find anything else online

Sorry :frowning:

The last thing I would try is to disable WiFi if you got the WiFi variant - just in case it's blocking the serial port for some reason.