Cannot connect Pi 3B+ to new network

I just replaced my router with a new TP-Link A7 dual band router. I have two separate Raspberry Pi 3b+ running Octoprint that were connected to the old router. I assumed that I would just have to update octopi-wpa-supplicant in the boot drive with the new network information, but this is not the case. Neither Pi is connecting and I have reimaged both SD cards several times. I know there will be different IP addresses with the new router, but they are not showing up in my router setup. I am able to octopi connect through Ethernet. Additionally, I tried running raspbian and I was able to connect to wifi via the GUI so Octoprint should be able to connect.

Other things that I tried:
+Verified that is not connected to wifi with ifconfig wlan0
+Verified that the pi can see my network with sudo iwlist wlan0 scan
+Verified this file /etc/wpa_supplicant/wpa_supplicant.conf

I am at a loss for what to try next. Any help would be greatly appreciated!

It turned out to be the special characters in my wifi password, specifically @. None of my other connected devices had this problem and I was able to connect my Pi when running Raspian.