Cannot connect to Ender-3 S1 via USB

What is the problem?

When trying to connect OctoPrint running on a Raspberry Pi 3 to my Creality Ender-3 S1, I am getting "Could not write to serial port".

I am using /dev/ttyAMA0, as no USB devices are coming up.

Has anyone got this working with Ender-3 S1?

What did you already try to solve it?

Reboot the Raspberry Pi with the printer connected.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Hmm. No.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1200.0
env.hardware.ram: 969768960
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.0.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.3
systeminfo.generator: zipapi

2022-02-19 11:55:06,090 - Enabling serial logging
2022-02-19 11:55:11,364 - Changing monitoring state from "Offline" to "Detecting serial connection"
2022-02-19 11:55:11,367 - Performing autodetection with 7 port/baudrate candidates: /dev/ttyAMA0@115200, /dev/ttyAMA0@250000, /dev/ttyAMA0@230400, /dev/ttyAMA0@57600, /dev/ttyAMA0@38400, /dev/ttyAMA0@19200, /dev/ttyAMA0@9600
2022-02-19 11:55:11,367 - Trying port /dev/ttyAMA0, baudrate 115200
2022-02-19 11:55:11,394 - Connecting to port /dev/ttyAMA0, baudrate 115200
2022-02-19 11:55:11,409 - Handshake attempt #1 with timeout 2.0s
2022-02-19 11:55:12,423 - Could not write anything to the serial port in 5 tries, something appears to be wrong with the printer communication
2022-02-19 11:55:12,430 - Changing monitoring state from "Detecting serial connection" to "Offline after error"
2022-02-19 11:55:12,433 - Closing down send loop

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Printer firmware is V1.0.3_C

I tried to run OctoPrint on may mac too, but got the same problem. Could not find any device that would connect. (No relevant devices showing up.)

You may try different USB cables. Some don't have data connection and are just for charging.

You're right! I had already tried two different cables, but when I tried the third, it worked.
Thanks a lot :slight_smile:

1 Like

Same Printer, same Problem. "Belker USB C Kabel Kurz 50cm" worked! See

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.