Cannot connect to my Prusa i3MKS+

What is the problem?

Cannot connect to my Prusa i3MKS+ with my RPi 3B+

What did you already try to solve it?

Removed some plugins

Have you tried running in safe mode?

Cannot find the option. I have the app running from an env and the yams file doesn't contain that option.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Firmware 3.12.1 (86.4 KB)

Hello @ebolisa !

Hint: Blue words are links :wink:

Your USB connection seems quite disturbed:

2023-03-28 13:53:59,260 - octoprint.util.comm - WARNING - Received line:
2023-03-28 13:53:59,260 - octoprint.util.comm - WARNING - | ݉Jˆ¡™€*0ÉÖ ®`\x00a!õŸ‘ß\x00Jԛ& \x00¹
2023-03-28 13:53:59,260 - octoprint.util.comm - WARNING - The received line contains at least one null byte character at position 14, this hints at some data corruption going on

You may try a better USB cable.

You have issues with your power supply:

2023-03-26 21:04:37,480 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.
2023-03-26 21:04:37,524 - octoprint.environment - INFO - Detected environment is Python 3.9.2 under Linux (linux). Details:
|  hardware:
|    cores: 4
|    freq: 1400.0
|    ram: 780054528
|  os:
|    bits: 32
|    id: linux
|    platform: linux
|  plugins:
|    pi_support:
|      model: Raspberry Pi 3 Model B Plus Rev 1.3
|      throttle_check_enabled: true
|      throttle_check_functional: true
|      throttle_state: '0xD0008'
|  python:
|    pip: 20.3.4
|    version: 3.9.2
|    virtualenv: /home/pi/OctoPrint

Please avid to restart the Pi by cutting off the power:

2023-03-26 00:23:55,540 - octoprint.server.util.sockjs - INFO - New connection from client:
2023-03-26 00:27:31,677 - octoprint.plugins.tracking - INFO - Sent tracking event system_unthrottled, payload: {'throttled_now': False, 'throttled_past': False, 'throttled_mask': 524288, 'throttled_voltage_now': False, 'throttled_voltage_past': False, 'throttled_overheat_now': False, 'throttled_overheat_past': False}
2023-03-26 00:32:25,077 - octoprint.startup - INFO - ******************************************************************************
2023-03-26 00:32:25,085 - octoprint.startup - INFO - Starting OctoPrint 1.8.7
2023-03-26 00:32:25,086 - octoprint.startup - INFO - ******************************************************************************

Thanks! I was aware of the link and that's why I said I could not find the the option in the config.yaml file. Will take a second look.

The USB cable is new and came with the printer. Will try a different one.

The under voltage warnings are old. I removed the Pi camera and that solved the problem.

Octoprint was working fine before I installed an USB camera. It maybe the problem. I'm considering re-inslalling the octoprint files.

Have you tried without the cam?

Yes, I did. The app tries to connect but doesn't lock in and that's with a different cable and w/o the new USB camera.

Where's the safe-mode at? As I said, it's not in the config file.

Somehow that icon is missing.

It should look like this:

I know! It may be due to the fact that I'm running the app in env? I'm not running it from an Octoprint OS.

I just re-installed the app but the problem is still present.
The Pi does detect the printer w/o a problem but octoprint, doesn't.

pi@piserver:~ $ lsusb
Bus 001 Device 010: ID 2c99:0002 Prusa Original Prusa i3 MK3
Bus 001 Device 005: ID 174c:0883 ASMedia Technology Inc. X883
Bus 001 Device 007: ID 0424:7800 Microchip Technology, Inc. (formerly SMSC)
Bus 001 Device 003: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Got it working. It appears the problem is baudrate related. Changed it to 115200 and started working :triumph:
Thank you!

1 Like