Cannot connect to octopi

What is the problem?

I cannot connect to Octopi, I know the IP number and can connect to the Raspberry Pi. Octopi tries to connect and immediately it disconnects

What did you already try to solve it?


Have you tried running in safe mode?

No how do I run in safe mode (I'm a newbie)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyS0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"
Unexpected error while connecting to serial port /dev/ttyS0, baudrate 115200 from hook default: SerialException: '[Errno 13] could not open port /dev/ttyS0: [Errno 13] Permission denied: '/dev/ttyS0'' @

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


from the error message it may well be that the user you run octoprint as is not in the groups tty and dialout. Assuming it is pi you would do that like:

sudo usermod -a -G tty pi
sudo usermod -a -G dialout pi

Just to clarify:

You try to connect OctoPrint to a printer with lan/wlan port?
Or you have trouble to connect from your Browser to OctoPrint?
Or you have trouble to connect to a printer with USB port?

It would be helpful to tell us what printer you have.

I have a Prusa I3 MK3S+

That won't do.
That template you get when opening a thread on Get Help is meant to structure your response, it's a task list. People can not magically scan your system and it's history, you need to supply all the details so there's a chance other readers get an idea what goes off on your side.
You chose to ignore that. This is completly fine but limits the possible response.
You're left with the alternative approach: search the treasures of info stored in this forum.

There is the Search, the FAQ. A starting point: Cant connect to my printer

1 Like

I had to set Rpi on off in my printer.
Thank you for help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.