OctoPrint can't connect to my printer

general

#1

There are a number of possible reasons for this:

  • You selected "AUTO" as port but your printer doesn't support auto connect. Try selecting the printer port manually, like it tells you to in the Terminal tab.
  • Your printer is resetting on connect and not getting ready fast enough for OctoPrint to perform a communication handshake in time. Make sure "Wait for start on connect" is checked under Settings > Features. If that doesn't help, try increasing the Connection timeout under Settings > Serial Connection.
  • Your printer does not support the communication protocol that OctoPrint speaks. You might need to install a plugin to be able to run your printer, e.g. the GPX plugin for Makerbot printer up to Gen 3 and various FlashForge, QIDI and other brand printers, or the M33Fio plugin for M3D Micro printers. If no plugin is available, it might be possible to write one, but that can only be done by someone with access to the printer model in question - a job for the community, that's what the plugin system is in place for!
  • You are trying to connect with the wrong baudrate. If you are seeing something like Recv: ?+??Qj????)???Rj??Q??.aV???????? when trying to connect this is the most likely cause.

Printer will not register on OctoPrint