Cannot connect to Octoprint server. Have a complicated network

I had Octoprint accessible when I was using a Netgear router. I have recently migrated my network over to OPNsense. Octoprint is running on a windows 10 laptop, following the proper guide from @foosel.

One thing to keep in mind, is that I haven't updated Octoprint in a few months.

Nonetheless, the laptop running Octoprint is on subnet 172.24.2, with an IP of This is also a wireless 5ghz VLAN, using a Unifi AC Pro as the AP. The VLAN IDs match with Unifi and OPNsense.

I do not have trouble accessing any other service across subnets/VLANs; samba, Unifi network controller, Home Assistant, etc.

I tried multiple browsers and Cura, on two different PCs. One computer is on the same wireless VLAN/subnet as Octoprint, and the other is on my LAN/subnet (no VLAN on LAN). No browser can reach Octoprint, and Cura cannot reach it. Both computers can remote desktop to the laptop running Octoprint just fine, using NoMachine. The laptop running Octoprint can access the running instance via its browser just fine.

I have a budding OPNsense install, and do not have any other rules on any interface assignment, other than allow all. No firewall rules are causing this. I definitely would appreciate help/suggestions on how to fix this. If reinstalling is necessary, I guess I'll have to do that...

Well crap...I just tried it on a PI 3B and it works just fine. Guess I might have to go that route. But I'd still like it if anyone had some pointers on my original problem.

Ok, now I feel stupid. It was Windows firewall on the laptop. But that doesn't make sense, because the firewall never blocked Octoprint before...

1 Like

#justwindowsthings :wink: :stuck_out_tongue: