Cannot connect to Octoprint via any PC, but can from my phone!

What is the problem?

Cannot connect to Octoprint via any PC, but can from my phone!
The octoprint server is refusing the connection. Error "192.168.1.140 refused to connect."

What did you already try to solve it?

Checked network connectivity on all devices, all devices have valid IP addresses, all devices can ping each other (phone to printer, printer to pc, pc to printer, pc to phone).

The interface all works perfectly via my phone, although its useless as I need it on my PC.

Cannot connect via Cura either.

Tried direct IP and octopi. Local both of which work on the phone.

Have tried removing all plugins with no change.

Have tried multiple pc's and browsers on PC.

Have you tried running in safemode?

My PC in safemode? No.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.8.1
Tried all pc browsers
Tired Windows 10 and 11
Only difference is PC is cabled and the phone is using WIFI

I worked around it by swapping my PC to Wifi. Its the same network and i could already ping the octoprint server but for some reason that fixed it. Must be a networking issue? Weird, I saw lots of other people that had the same issue, might be why they had it too.