Cannot connect to Octoprint

What is the problem?

--I cannot use a browser to call to the octopi service. I've used both octopi.local and the ip address and neither work

--I have a Raspberry Pi 4B with 2 GB RAM
--I am using a power supply for the Raspberry Pi, not a charger ... not a knock-off brand.

What did you already try to solve it?

--I have etched the SD card and used the Raspberry Pi application in an attempt to write the latest to the SD card.
--Etching the card doesn't allow connection to my router (even after updating the settings for my router and country). The Raspberry Pi application allows connection to my router, but I cannot connect to the service through a browser. I get an ERR_CONNECTION_REFUSED error.

--I have not yet connected the Raspberry Pi to my printer yet.

--I can connect to it using Putty/SSH
--I can ping the ip and get a response

Have you tried running in safe mode?

--no, how do I do this?

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

--I don't understand where I can get this from if I cannot connect to it through a browser

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

--using Raspberry Pi Imager v1.7.1
--Tried connecting using Chrome and MS Edge
--My computer is using Windows 10

Thank you for any help that can be provided

Have you changed the username when you used the RPi imager to flash it? If so, don't.

Doing that should usually at least show a page that says 'OctoPrint not running' though, to help figure out the issue.

I didn't change the username, but I did supply a password

So ... I'm an idiot. I wasn't adding the Octoprint OS to the SD card, I was adding the generic Raspberry PI OS to the SD card. Once I followed the correct instructions for the RPi imager ... I can now connect.

Thanks for anyone who looked at my post. Frustrating couple of days


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.