Cannot connect to printer after config update and firmware_restart

What is the problem?

Yesterday I updated to 1.10.1. I was able to connect to my printer as usual. This morning, I made some changes to printer.cfg and did a firmware_restart, but it dropped the connection to my printer and now will not connect with any connection parameters. The changes to printer.cfg were adding gcode macros for my runout sensor and adding input shaping back as I had commented it out for tuning purposes.

What did you already try to solve it?

Reverted printer.cfg and tried firmware_restart. Rebooted into safe mode, tried auto serial and baud rate detection.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (126.9 KB)

Additional information about your setup

OctoPrint 1.10.1
Ender 5 Pro
RPi 3B+

Your log looks like you keep trying to connect to /dev/ttyUSB0. While this is probably your printer, it is running Klipper so OctoPrint cannot directly connect to this port. The other half of Klipper (that does most of the work) runs on your Pi and connects to it. OctoPrint connects directly to the Klipper firmware, normally using a /tmp/printer port.


Thanks for the response Charlie!

So I understand what you are saying, however I changed nothing related to my physical printer, and this occurred. I am wondering how this could be possible. It worked totally fine for months, and then I make a config change per normal and this result.

I will probably try a fresh install of everything, but wondering how I can figure out what changed with the install.

OctoPrint is still up, just can't connect to my printer with same params.

It definitely seems like a Klipper side problem - OctoPrint seems to be working fine, as you've said. I don't know how you can best troubleshoot Klipper config/setup issues, but the Klipper community should know better.

1 Like

Have a look on this:

and for further questions go here:

1 Like

Thanks again for the responses fam!

So was lookin on my RPi yesterday, and noticed that I see no Klipper service running, even after a manual start..

My main concern is the action that caused this was a firmware_restart from OctoPrint. I understand that it is not OctoPrint itself that seems to be the issue, however, it is too coincidental that issuing a restart from the terminal in OctoPrint directly engendered this failure. It's possible it was random, but who knows. Was hoping someone had seen this issue before, and the community knew some troubleshooting steps. I'll look over on klippers reddit.

I really recommend the genuine Klipper forum mentioned above with support of the devs.

1 Like