Cannot Connect to Printer Octopi 1.3.11

What is the problem?
Cannot connect to printer, running a Makergear M2 Rev E, have basically always used octoprint but moved last year and only recently got my printer setup again. Ran a print (updated octorpint before and after if I recall correctly), then the next time I went to use my printer the CSS wouldn't load (I think that was the problem, and I think I solved that problem by re-connecting the pi camera as it hasn't happened since I reconnected the camera). But now octoprint seems to be working except it can't connect to the printer.

installed octopi 1.3.11 this morning

What did you already try to solve it?
I've tried to connect at all of the baud rate options

I activated serial logging and then tried to manually connect to each of the different baud rate options, the pastebin link below is my subsequent octoprint.log

the following pastebin link is my subsequent serial.log

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

As mentioned, running octopi 1.3.11 as of this morning, but had the problem prior to this update. Raspberry Pi 3B, Makergear M2 Rev E. Not sure how to check firmware. Accessing from windows. I have a raspberry pi camera installed, but no other hardware than the printer, the pi, and the camera. I've got a few plug-ins installed.

*** Edit: Added serial.log pastebin link

First things first, try it in Safe Mode. If it then works then troubleshoot the plugins you added like Anywhere. (Maybe you need to reconfigure your public IP address for that now that you've moved.)

  • Looks like you need a new version of OctoPrint Anywhere which works happily with Raspbian Buster and OctoPrint 1.3.11. Yours is triggering a security complaint regarding
  • Ignore the temporary loss of the CSS style sheet. Looks like you tried to access the web interface when OctoPrint was trying to build all the webpack stuff.
  • Verify that the (same) serial cable from before the move is being used, it's connected well at both ends of the cable. The cable needs to have internal metallic shielding or it needs a ferrite core.
  • If you have other USB-based things connected other than the printer, try removing them and retest.
  • Verify that you're using the same power adapter for the Pi as you did before the move.
  • Try manually setting the port and baudrate which you think the printer needs.
  • octoprint anywhere is up to date, I uninstalled it to be sure and problem is unchanged
  • Problem persists in safe mode, even after I uninstalled octoprint anywhere
  • can confirm, same serial and power cables in use as before
  • No other hardware aside from pi, printer, and pi camera. Nothing else connected to USB
  • my default settings were for the baud rate the printer uses (115200), it wont work on that setting or any of the other choices

It sounds like the author of OctoPrint Anywhere needs to update his/her code, for what it's worth (even if they've not fixed it yet).

I can relate to the recent move. I moved from SOCAL to NORCAL perhaps two months ago and just unboxed my own 3D printer. Similarly, I had difficulties getting everything re-connected. I didn't, though, choose to upgrade my OctoPrint when prompted. I didn't want to add yet one more variable to the troubleshooting.

So now you're looking at some sort of incompatibility with OctoPrint 1.3.11 with your rig or... something's changed in your setup or... your environment. (Less power at the wall outlet, more electromagnetic interference, etc.)

I wouldn't also adjust your firmware in a case like this since you knew it was working before. But an M115 once connected would tell you what it is. Yeah, I know: Catch-22.

You indicated that you were successful by reconnecting your Pi camera. Try disconnecting it and rebooting.

The weird thing with the move is, I've had a few prints off, did a test print and then printed a case for the pi to mount to my printer (no time like the present to actually work on the setup), so that was 3 successful prints before it stopped working. Also worth noting, I didn't have the pi camera installed pre-move. Hooked that up for the first time upon setting up at the new place about a month ago. I had un-installed it at one point to test fit the case I just printed and didn't bother plugging it back in because I was waiting for a new longer ribbon cable. Thats when I had the css problem, the pi was completely frozen and I had to hard reset it.

I might just reflash my sd card if I can't get it working soon

One strategy is to go as vanilla as you can, get it working and then add the "flavors" back in. Run Safe Mode, no camera, Ethernet cable connection, etc. If it still doesn't work at least you're looking at fewer pieces which could be the problem.

Egg on my face moment incoming:
I decided to remove as many variables as possible, so I removed the pi outright and connected the printer directly to my laptop. I couldn't get my laptop to communicate either, so there was something wrong with the printer.

I did some troubleshooting on the printer only to find that (somehow, not clear on how this could have happened) the power supply got disconnected from the printer. Haven't reconnected my octopi setup yet but fairly confident that the problem is solved.

1 Like