Cannot connect to printer using Octoprint

Being new to 3d printing, Octoprint AND a Linux environment, I can't get Octoprint (running in web browser on a Windows 10 system) to connect to my Prusa i3 Mk3S (firmware version 3.8.0).

I have spent a good bit of time trying to get this to work before posting, without luck. Here's what I've done:

  • installed my RaspberryPi Zero W into my printer. The micro SD card has been flashed with OctoPi 0.16.0. Turned my printer on, and set the RPi setting for my printer to On. Using PuTTY, I connected to it wirelessly, and using my browser (Firefox, most recent version), I can connect to the server as well. I ran the following commands to prepare to install PrusaMeshMap.
/home/pi/oprint/bin/pip --no-cache-dir install 'numpy<1.17'
/home/pi/oprint/bin/pip --no-cache-dir install 'matplotlib<3.0'

I realize these are installing older versions, but PrusaMeshMap can't be installed with the new versions.

PMM installed fine, and it shows up in the Octoprint browser window, but I can't connect to the printer to use it. I also connected with the serial cable that came with my printer. The printer shows as Offline on the left side of the Octoprint window, and all my attempts to manually configure the serial port have not worked either. I tried baud rates, tried to add a port manually since the only option in the drop down menu is Auto, which didn't work, but I don't know what kind of port address it wants for the USB slot I plugged it into. I have tried suggestions in other posts on here, but nothing has worked. The log was nothing but saying it was switching from Connecting to Offline, and that I should try to configure the serial port manually.

I'm completely stumped. Any help would be greatly appreciated.

If I remember correctly you have to disable the rpi setting on your printer if you use a usb cable.

I never used a gpio serial connection to the printer so I can't help you with this part.

Also please note that contrary to what prusa recommends for their printers, I (the person who wrote OctoPrint) do not recommend running it on a 0w due to serious performance issues caused by the way the WiFi is internally attached. Which I'd also have told them if they had asked before designing things they did. Which they didn't.


I read that in about post as well, but disabling it didn't make any difference. I will try it again to make sure.

I remember reading that as well foosel. I'm willing to switch from the 0W if that's a better option, but I hate to spend the money if I won't be able to get Prusa Mesh Map to work. At the moment, it's really the only reason I did all of this. Can you direct me to a thread, or give me recommendations for what I should get to replace the 0W? I don't necessarily need the wireless at the moment, but possibly in the future. I'm happy to connect with a cable for the time being if need be. Thanks for the reply foosel!

I would suggest a Pi 3+. It got wifi dualband, is pretty fast and doesn't run as hot as the pi 4.

We should test if your printer is recognized at all.
Disconnect the usb cable, connect it again, enter dmesg | tail -n 20 in putty and post the output here.

Connecting the printer to my computer, it does show up under connected devices. Here is the result of the dmesg command. Also, the RPi port is set to Off on the printer.

[ 14.535611] uart-pl011 20201000.serial: no DMA platform data
[ 16.320183] Adding 102396k swap on /var/swap. Priority:-2 extents:1 across:102396k SSFS
[ 17.775089] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 17.775109] brcmfmac: power management disabled
[ 19.101160] Bluetooth: Core ver 2.22
[ 19.101286] NET: Registered protocol family 31
[ 19.101294] Bluetooth: HCI device and connection manager initialized
[ 19.101317] Bluetooth: HCI socket layer initialized
[ 19.101332] Bluetooth: L2CAP socket layer initialized
[ 19.101375] Bluetooth: SCO socket layer initialized
[ 19.116636] Bluetooth: HCI UART driver ver 2.3
[ 19.116654] Bluetooth: HCI UART protocol H4 registered
[ 19.116659] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 19.133073] Bluetooth: HCI UART protocol Broadcom registered
[ 19.692116] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 19.692129] Bluetooth: BNEP filters: protocol multicast
[ 19.692154] Bluetooth: BNEP socket layer initialized
[ 22.620991] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 129.350276] random: crng init done
[ 129.350297] random: 7 urandom warning(s) missed due to ratelimiting

Well there is nothing.
I would try to reset the printers settings (clear eeprom) and use other usb cables

Thanks @PrintedWeezl. I cleared the printers EEPROM, and tried it again, with no luck. I've ordered a RPi 3 B+, so once it gets here, I will try it again. I don't think it's the cable, because Windows still recognizes that my printer is connected, so I'm guessing that something just isn't right with the 0W. Can you tell me what I should be looking for in the dmesg results to show that it's seeing the printer? I'll reply again here once the 3B+ gets here and I test it with the new board.

1 Like

sure. That's how it looks like after I connected my printer via usb

pi@octopi:~ $ dmesg | tail -n 20
[   14.005793] Bluetooth: HCI UART driver ver 2.3
[   14.005800] Bluetooth: HCI UART protocol H4 registered
[   14.005833] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   14.005929] Bluetooth: HCI UART protocol Broadcom registered
[   14.287152] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.287158] Bluetooth: BNEP filters: protocol multicast
[   14.287169] Bluetooth: BNEP socket layer initialized
[   14.342126] Bluetooth: RFCOMM TTY layer initialized
[   14.342141] Bluetooth: RFCOMM socket layer initialized
[   14.342164] Bluetooth: RFCOMM ver 1.11
[  112.504847] usb 1-1.4: new full-speed USB device number 5 using xhci_hcd
[  112.613099] usb 1-1.4: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.63
[  112.613106] usb 1-1.4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  112.613110] usb 1-1.4: Product: USB2.0-Serial
[  112.652763] usbcore: registered new interface driver usbserial_generic
[  112.653040] usbserial: USB Serial support registered for generic
[  112.655699] usbcore: registered new interface driver ch341
[  112.655815] usbserial: USB Serial support registered for ch341-uart
[  112.655869] ch341 1-1.4:1.0: ch341-uart converter detected
[  112.658867] usb 1-1.4: ch341-uart converter now attached to ttyUSB0

The last line tells you how your serial interface is called in octoprint (ttyUSB0 in my case)

1 Like

Got my RPi 3 B+ setup and connected just now. Just wanted to check in with you all and let you know that it now recognizes and connects to the printer as it should. Must have been an issue with the 0W. Thank you for all the help @PrintedWeezl !

1 Like