Cannot connect to Qidi X-Max 3 printer

What is the problem?

Every time it tries to connect my Qidi X-Max 3 printer to Octoprint, I keep getting

Could not autodetect your printer

No working connection parameters could be found. Are you sure your printer is physically connected and supported? Refer to the FAQ for help in debugging this.

I am trying to connect through the included cat5 ports on my pi B and the printer. There is no other connection on the printer. I have contacted Qidi support, and all they can tell me is that the printer supports Raspberry Pi via the network cable. I am a true nube when using the Raspberry Pi. I have checked and I have the latest version of Octopi installed.

What did you already try to solve it?

I tried using information from this community from this post Failed to auto detect serial port (Qidi X-pro) - #45 by lulukul

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20240101125655.zip (24.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.9.3, 1.0.0, Qidi X-Max 3, V4.3.10, Chrome, Windows 10, Raspberrypi B

Hello @dmullins !

You may have to try this plugin:

I haven't. Where do I do this?

You can find it in OctoPrint's Plugin Manager.

I installed it, restarted Octoprint and I still cannot connect.

Normally, OctoPrint connects to a serial device that would be connected via USB. For almost every other setup than connecting via USB, you will need to do some extra setup. I'd think it would be highly unlikely that just plugging in the Cat5 cable you will get a working connection.

I've just googled this printer, and it looks like it is running Klipper firmware on the printer already, with the Fluidd UI installed. Apparently, if the printer is connected to your network, and you go to http://IP:10088 you find the fluidd UI. Not sure if that is correct, or how it's setup - outside my knowledge.

Given this printer is running Klipper, with no USB port available, to install OctoPrint you would have to install it alongside Klipper on the main board of the printer, so it could communicate with the firmware there. No idea how to do that as I don't know how open the software is for you to get in and modify things.

Thanks, @Charlie_Powell. I am going off what Qidi customer service told me about connecting with a network cable to the Raspberry Pi. Maybe someone has had success?

The printer does have Kipper firmware and I can connect to it via wifi just fine. I wanted to use Octoeverywhere to start a print job and monitor them when I am not in front of my computer.

Trying to figure out how to add it to the main board is way out of my mindset.

There is a OctoEverywhere version for Klipper that works fine with a genuine Klipper install.

Maybe not with a pre installed Klipper.